summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-05-23 17:17:42 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-05-23 17:17:42 +0000
commit8a68aebaa0b15494965b9cb3f46faecfeb6164c4 (patch)
tree85769aef63fb52e9f2cecf68bfd8b6ec2e1a968f /www-servers
parentVersion bump. Removed old. Added rewritten init script (diff)
downloadgentoo-2-8a68aebaa0b15494965b9cb3f46faecfeb6164c4.tar.gz
gentoo-2-8a68aebaa0b15494965b9cb3f46faecfeb6164c4.tar.bz2
gentoo-2-8a68aebaa0b15494965b9cb3f46faecfeb6164c4.zip
respect CFLAGS
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/hiawatha/ChangeLog6
-rw-r--r--www-servers/hiawatha/files/hiawatha-9.5-cflags.patch17
-rw-r--r--www-servers/hiawatha/hiawatha-9.5.ebuild4
3 files changed, 25 insertions, 2 deletions
diff --git a/www-servers/hiawatha/ChangeLog b/www-servers/hiawatha/ChangeLog
index 8c15fb6858c4..c9acff9041de 100644
--- a/www-servers/hiawatha/ChangeLog
+++ b/www-servers/hiawatha/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/hiawatha
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/ChangeLog,v 1.2 2014/05/22 13:19:10 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/ChangeLog,v 1.3 2014/05/23 17:17:42 hasufell Exp $
+
+ 23 May 2014; Julian Ospald <hasufell@gentoo.org>
+ +files/hiawatha-9.5-cflags.patch, hiawatha-9.5.ebuild:
+ respect CFLAGS
22 May 2014; Julian Ospald <hasufell@gentoo.org> hiawatha-9.5.ebuild:
add ~x86 keyword
diff --git a/www-servers/hiawatha/files/hiawatha-9.5-cflags.patch b/www-servers/hiawatha/files/hiawatha-9.5-cflags.patch
new file mode 100644
index 000000000000..4ff33cd0d126
--- /dev/null
+++ b/www-servers/hiawatha/files/hiawatha-9.5-cflags.patch
@@ -0,0 +1,17 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri May 23 16:59:33 UTC 2014
+Subject: make optimization level build-type dependant
+
+--- hiawatha-9.5/CMakeLists.txt
++++ hiawatha-9.5/CMakeLists.txt
+@@ -2,7 +2,9 @@
+ project(Hiawatha C)
+
+ # Compiler
+-set(CMAKE_C_FLAGS "-O2 -Wall -Wextra ${CMAKE_C_FLAGS}")
++set(CMAKE_C_FLAGS "-Wall -Wextra ${CMAKE_C_FLAGS}")
++set(CMAKE_C_FLAGS_RELEASE "-O2")
++set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2")
+ set(CMAKE_BUILD_TYPE "RelWithDebInfo")
+
+ # Options
diff --git a/www-servers/hiawatha/hiawatha-9.5.ebuild b/www-servers/hiawatha/hiawatha-9.5.ebuild
index 16cfd34d2db6..9ea03746d846 100644
--- a/www-servers/hiawatha/hiawatha-9.5.ebuild
+++ b/www-servers/hiawatha/hiawatha-9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/hiawatha-9.5.ebuild,v 1.2 2014/05/22 13:19:10 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/hiawatha-9.5.ebuild,v 1.3 2014/05/23 17:17:42 hasufell Exp $
EAPI=5
@@ -35,6 +35,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9.5-cflags.patch
+
rm -r polarssl || die
grep '#ServerId =' config/hiawatha.conf.in 1>/dev/null || die