summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-12-02 06:43:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-12-02 06:43:42 +0000
commitb53fce867ffd2a81cf2b364be75966fdc8871355 (patch)
treeed08551b89dacf54b87b4a32aa1458bedfe32352 /www-servers
parentBug #347227: add in mod_reqtimeout (for use on Gentoo Infra). Also add mod_pr... (diff)
downloadgentoo-2-b53fce867ffd2a81cf2b364be75966fdc8871355.tar.gz
gentoo-2-b53fce867ffd2a81cf2b364be75966fdc8871355.tar.bz2
gentoo-2-b53fce867ffd2a81cf2b364be75966fdc8871355.zip
Bug #347227: add in mod_reqtimeout (for use on Gentoo Infra). Also add mod_proxy_scgi and document all other modules that are not included.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog8
-rw-r--r--www-servers/apache/apache-2.2.16-r1.ebuild100
2 files changed, 107 insertions, 1 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index a9d22eb283bf..cd62051f1982 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.146 2010/09/19 17:41:21 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.147 2010/12/02 06:43:42 robbat2 Exp $
+
+*apache-2.2.16-r1 (02 Dec 2010)
+
+ 02 Dec 2010; Robin H. Johnson <robbat2@gentoo.org> +apache-2.2.16-r1.ebuild:
+ Bug #347227: add in mod_reqtimeout (for use on Gentoo Infra). Also add
+ mod_proxy_scgi and document all other modules that are not included.
19 Sep 2010; Guy Martin <gmsoft@gentoo.org> apache-2.2.16.ebuild:
hppa stable wrt #330195
diff --git a/www-servers/apache/apache-2.2.16-r1.ebuild b/www-servers/apache/apache-2.2.16-r1.ebuild
new file mode 100644
index 000000000000..62922836a2ff
--- /dev/null
+++ b/www-servers/apache/apache-2.2.16-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.16-r1.ebuild,v 1.1 2010/12/02 06:43:42 robbat2 Exp $
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20100828"
+GENTOO_DEVELOPER="hollow"
+# We want the patch from r0
+GENTOO_PATCHNAME="gentoo-${P}"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
+env expires ext_filter file_cache filter headers ident imagemap include info
+log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
+proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
+reqtimeout setenvif speling status substitute unique_id userdir usertrack
+version vhost_alias"
+# The following are also in the source as of this version, but are not available
+# for user selection:
+# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
+# optional_fn_import optional_hook_export optional_hook_import
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ proxy_scgi:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+RDEPEND="${RDEPEND}
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_mime? ( app-misc/mime-types )"