summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-10-22 18:13:50 +0000
committerThilo Bangert <bangert@gentoo.org>2008-10-22 18:13:50 +0000
commitbb2459a1e71e9df9e686405dc7fe3cba1e72634e (patch)
tree37558fc478b4def786d1220ee5bd54ab5d0585b1 /www-servers
parentVersion bump. Translation updates. (diff)
downloadgentoo-2-bb2459a1e71e9df9e686405dc7fe3cba1e72634e.tar.gz
gentoo-2-bb2459a1e71e9df9e686405dc7fe3cba1e72634e.tar.bz2
gentoo-2-bb2459a1e71e9df9e686405dc7fe3cba1e72634e.zip
version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/varnish/ChangeLog7
-rw-r--r--www-servers/varnish/varnish-2.0.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 2819fe7875bc..57ae84321aff 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.14 2008/03/10 22:10:20 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.15 2008/10/22 18:13:50 bangert Exp $
+
+*varnish-2.0.1 (22 Oct 2008)
+
+ 22 Oct 2008; Thilo Bangert <bangert@gentoo.org> +varnish-2.0.1.ebuild:
+ version bump
10 Mar 2008; Thilo Bangert <bangert@gentoo.org> files/varnishd.initd:
allow varnish to lock the logfile to memory - the next version of varnish
diff --git a/www-servers/varnish/varnish-2.0.1.ebuild b/www-servers/varnish/varnish-2.0.1.ebuild
new file mode 100644
index 000000000000..f11134c34d47
--- /dev/null
+++ b/www-servers/varnish/varnish-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-2.0.1.ebuild,v 1.1 2008/10/22 18:13:50 bangert Exp $
+
+inherit eutils
+
+DESCRIPTION="Varnish is an HTTP accelerator"
+HOMEPAGE="http://varnish.projects.linpro.no/"
+SRC_URI="mirror://sourceforge/varnish/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+#varnish compiles stuff at run time
+RDEPEND="sys-devel/gcc"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/varnishd.initd varnishd || die
+ newconfd "${FILESDIR}"/varnishd.confd varnishd || die
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+ echo
+}