summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2006-05-16 16:58:11 +0000
committerThilo Bangert <bangert@gentoo.org>2006-05-16 16:58:11 +0000
commitbc1656f0998f34e0417226fabfe1ccc0d42cb2db (patch)
treea3870e1e1e81a8b55b765c2f4dbe52d96e025663 /www-servers
parentFix bug 133409 and other sandbox violations i hope. Also put this in ~arch. (diff)
downloadgentoo-2-bc1656f0998f34e0417226fabfe1ccc0d42cb2db.tar.gz
gentoo-2-bc1656f0998f34e0417226fabfe1ccc0d42cb2db.tar.bz2
gentoo-2-bc1656f0998f34e0417226fabfe1ccc0d42cb2db.zip
added old version - has the security fix, but not the incompatible configuration file change (bug #118541)
(Portage version: 2.0.54-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog8
-rw-r--r--www-servers/pound/Manifest2
-rw-r--r--www-servers/pound/files/digest-pound-1.101
-rw-r--r--www-servers/pound/pound-1.10.ebuild50
4 files changed, 60 insertions, 1 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 9c36db050540..8470b9399b69 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pound
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.16 2006/05/16 11:49:57 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.17 2006/05/16 16:58:11 bangert Exp $
+
+*pound-1.10 (16 May 2006)
+
+ 16 May 2006; Thilo Bangert <bangert@gentoo.org> +pound-1.10.ebuild:
+ added old version - has the security fix, but not the incompatible
+ configuration file change (bug #118541)
16 May 2006; Thilo Bangert <bangert@gentoo.org> -pound-1.7.ebuild,
-pound-1.8.3.ebuild:
diff --git a/www-servers/pound/Manifest b/www-servers/pound/Manifest
index 274be8c0ece4..c888815ecde7 100644
--- a/www-servers/pound/Manifest
+++ b/www-servers/pound/Manifest
@@ -1,4 +1,5 @@
MD5 4a58785b0b5d538a03efaef84c4a4d8d ChangeLog 3630
+MD5 f1d37788ebac1a6b519cd9ae81593c00 files/digest-pound-1.10 59
MD5 d15f0a09b8947377df0afdedaf3a50a3 files/digest-pound-1.9 58
MD5 bcca392bc76d616e4b38f8092402d417 files/digest-pound-2.0.3 226
MD5 1dc035075c85945c0b99b3838ebdec1c files/digest-pound-2.0.5 60
@@ -7,6 +8,7 @@ MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
MD5 887a882063050c34c66dcfb8091711bf files/pound.init 583
MD5 8ed6124c94dc41416049aedd7355d595 files/pound.init-1.9 609
MD5 5bf55540b34f63fe561c545abdfee3fb metadata.xml 666
+MD5 2fa8ecf1375f09e34e5853c742021e6b pound-1.10.ebuild 1162
MD5 2fa8ecf1375f09e34e5853c742021e6b pound-1.9.ebuild 1162
MD5 e0407067e38b3e6b2d468b040ad69b9b pound-2.0.3.ebuild 1216
MD5 b2a51b7113bfe0a04c4116cc19fa9ea0 pound-2.0.5.ebuild 1355
diff --git a/www-servers/pound/files/digest-pound-1.10 b/www-servers/pound/files/digest-pound-1.10
new file mode 100644
index 000000000000..22185fc4caf5
--- /dev/null
+++ b/www-servers/pound/files/digest-pound-1.10
@@ -0,0 +1 @@
+MD5 5792fd804907cc617e37607c6783d5f7 Pound-1.10.tgz 145616
diff --git a/www-servers/pound/pound-1.10.ebuild b/www-servers/pound/pound-1.10.ebuild
new file mode 100644
index 000000000000..25ca05002d7d
--- /dev/null
+++ b/www-servers/pound/pound-1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.10.ebuild,v 1.1 2006/05/16 16:58:11 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
+IUSE="ssl msdav unsafe static"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable msdav) \
+ $(use_enable unsafe) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README FAQ
+
+ newinitd ${FILESDIR}/${PN}.init-${PV} ${PN}
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}