summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-07 08:22:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-07 08:22:06 +0000
commite0ef10d0bbe2548f6599557f7b580cff322c7bd4 (patch)
tree49c36b9fcd2f9d271d3f7c0a756deb476ac5c8ca /www-servers
parent[bump] dev-perl/SVG-2.520.0 (diff)
downloadgentoo-2-e0ef10d0bbe2548f6599557f7b580cff322c7bd4.tar.gz
gentoo-2-e0ef10d0bbe2548f6599557f7b580cff322c7bd4.tar.bz2
gentoo-2-e0ef10d0bbe2548f6599557f7b580cff322c7bd4.zip
Version bump, fix init script
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/ChangeLog8
-rw-r--r--www-servers/monkeyd/files/monkeyd.confd6
-rw-r--r--www-servers/monkeyd/files/monkeyd.initd26
-rw-r--r--www-servers/monkeyd/monkeyd-1.0.0.ebuild70
4 files changed, 109 insertions, 1 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index 4a28b716acdc..05d7aa725f36 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/monkeyd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.33 2012/05/23 15:42:00 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.34 2012/06/07 08:22:05 blueness Exp $
+
+*monkeyd-1.0.0 (07 Jun 2012)
+
+ 07 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +monkeyd-1.0.0.ebuild,
+ +files/monkeyd.confd, +files/monkeyd.initd:
+ Version bump, fix init script
*monkeyd-0.33.0-r1 (23 May 2012)
diff --git a/www-servers/monkeyd/files/monkeyd.confd b/www-servers/monkeyd/files/monkeyd.confd
new file mode 100644
index 000000000000..ad867ee182aa
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd.confd
@@ -0,0 +1,6 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/files/monkeyd.confd,v 1.1 2012/06/07 08:22:06 blueness Exp $
+
+# Add any additional command line arguments here
+MONKEY_ARGS=""
diff --git a/www-servers/monkeyd/files/monkeyd.initd b/www-servers/monkeyd/files/monkeyd.initd
new file mode 100644
index 000000000000..5f3ef96ebaa1
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/files/monkeyd.initd,v 1.1 2012/06/07 08:22:06 blueness Exp $
+
+DAEMON="/usr/bin/monkey"
+CONFFILE="/etc/monkeyd/monkey.conf"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting monkeyd"
+ start-stop-daemon --start --exec "${DAEMON}" -- "-D" "${MONKEY_ARGS}" >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping monkeyd"
+ local PORT=$(awk '/^ *Port/ { print $2 }' "${CONFFILE}")
+ local PIDFILE=$(awk '/^ *PidFile/ { print $2 }' "${CONFFILE}")
+ PIDFILE="${PIDFILE}"."${PORT}"
+ start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
+ eend $?
+}
diff --git a/www-servers/monkeyd/monkeyd-1.0.0.ebuild b/www-servers/monkeyd/monkeyd-1.0.0.ebuild
new file mode 100644
index 000000000000..c7235d1998bc
--- /dev/null
+++ b/www-servers/monkeyd/monkeyd-1.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-1.0.0.ebuild,v 1.1 2012/06/07 08:22:05 blueness Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs depend.php multilib
+
+WEBROOT="/var/www/localhost"
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="A small, fast, and scalable web server"
+HOMEPAGE="http://www.monkey-project.com/"
+SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="php"
+
+RDEPEND="php? ( virtual/httpd-php )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use php && require_php_cgi
+}
+
+src_prepare() {
+ # Don't install the banana script, we use ${FILESDIR}/monkeyd.initd
+ sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
+
+ # Don't explicitly strip files
+ sed -i -e '/$STRIP /d' -e 's/install -s -m 644/install -m 755/' configure || die
+}
+
+src_configure() {
+ # Non-autotools configure
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --mandir=/usr/share/man \
+ --plugdir=/usr/$(get_libdir)/monkeyd/plugins \
+ --sysconfdir=/etc/${PN} \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+
+ # Don't install the banana script man page
+ rm "${S}"/man/banana.1
+}
+
+src_install() {
+ default
+
+ if use php ; then
+ sed -i -e '/^#AddScript application\/x-httpd-php/s:^#::' "${D}"/etc/monkeyd/monkey.conf || die
+ sed -i -e 's:/home/my_home/php/bin/php:/usr/bin/php-cgi:' "${D}"/etc/monkeyd/monkey.conf || die
+ fi
+
+ mv "${D}"${WEBROOT}/htdocs/{index,index-monkey}.html
+
+ sed -i -e "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" "${D}"/etc/monkeyd/monkey.conf || die
+ newinitd "${FILESDIR}"/monkeyd.initd monkeyd
+ newconfd "${FILESDIR}"/monkeyd.confd monkeyd
+}