summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-01-01 20:33:10 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-01-01 20:33:10 +0000
commite9acd2e938d5dd0a5b7c1407602b46e6e4820296 (patch)
tree76bc7233c272a4067ccdce22d40b457f02e2006b /www-servers
parentVersion bump. Fixes bug 256080. (diff)
downloadgentoo-2-e9acd2e938d5dd0a5b7c1407602b46e6e4820296.tar.gz
gentoo-2-e9acd2e938d5dd0a5b7c1407602b46e6e4820296.tar.bz2
gentoo-2-e9acd2e938d5dd0a5b7c1407602b46e6e4820296.zip
Fix problems with -ssl compilation of www-servers/nginx (see bug 293785).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/nginx-0.7.64.ebuild10
-rw-r--r--www-servers/nginx/nginx-0.8.29.ebuild10
3 files changed, 16 insertions, 12 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 204626d0abd5..4a7f17f82b85 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/nginx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.231 2009/12/08 14:49:37 djc Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.232 2010/01/01 20:33:10 djc Exp $
+
+ 01 Jan 2010; Dirkjan Ochtman <djc@gentoo.org> nginx-0.7.64.ebuild,
+ nginx-0.8.29.ebuild:
+ Fix problems with ssl requirements (see bug 293785 for discussion).
*nginx-0.8.29 (08 Dec 2009)
*nginx-0.7.64 (08 Dec 2009)
diff --git a/www-servers/nginx/nginx-0.7.64.ebuild b/www-servers/nginx/nginx-0.7.64.ebuild
index 7e65b5d2a4ad..d4a3fb7818c4 100644
--- a/www-servers/nginx/nginx-0.7.64.ebuild
+++ b/www-servers/nginx/nginx-0.7.64.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.64.ebuild,v 1.1 2009/12/08 14:49:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.64.ebuild,v 1.2 2010/01/01 20:33:10 djc Exp $
inherit eutils ssl-cert toolchain-funcs
@@ -14,8 +14,8 @@ KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="addition debug fastcgi flv imap pcre perl random-index ssl status sub webdav zlib"
DEPEND="dev-lang/perl
+ dev-libs/openssl
pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
zlib? ( sys-libs/zlib )
perl? ( >=dev-lang/perl-5.8 )"
@@ -64,6 +64,8 @@ src_compile() {
tc-export CC
./configure \
--prefix=/usr \
+ --with-cc-opt="-I${ROOT}/usr/include" \
+ --with-ld-opt="-L${ROOT}/usr/lib" \
--conf-path=/etc/${PN}/${PN}.conf \
--http-log-path=/var/log/${PN}/access_log \
--error-log-path=/var/log/${PN}/error_log \
@@ -71,8 +73,6 @@ src_compile() {
--http-client-body-temp-path=/var/tmp/${PN}/client \
--http-proxy-temp-path=/var/tmp/${PN}/proxy \
--http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
${myconf} || die "configure failed"
emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
diff --git a/www-servers/nginx/nginx-0.8.29.ebuild b/www-servers/nginx/nginx-0.8.29.ebuild
index 95f1dec2948a..920b1dd7c2c6 100644
--- a/www-servers/nginx/nginx-0.8.29.ebuild
+++ b/www-servers/nginx/nginx-0.8.29.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.29.ebuild,v 1.1 2009/12/08 14:49:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.29.ebuild,v 1.2 2010/01/01 20:33:10 djc Exp $
inherit eutils ssl-cert toolchain-funcs
@@ -14,8 +14,8 @@ KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="addition debug fastcgi flv imap ipv6 pcre perl random-index securelink ssl status sub webdav zlib"
DEPEND="dev-lang/perl
+ dev-libs/openssl
pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
zlib? ( sys-libs/zlib )
perl? ( >=dev-lang/perl-5.8 )"
@@ -71,6 +71,8 @@ src_compile() {
tc-export CC
./configure \
--prefix=/usr \
+ --with-cc-opt="-I${ROOT}/usr/include" \
+ --with-ld-opt="-L${ROOT}/usr/lib" \
--conf-path=/etc/${PN}/${PN}.conf \
--http-log-path=/var/log/${PN}/access_log \
--error-log-path=/var/log/${PN}/error_log \
@@ -78,8 +80,6 @@ src_compile() {
--http-client-body-temp-path=/var/tmp/${PN}/client \
--http-proxy-temp-path=/var/tmp/${PN}/proxy \
--http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
${myconf} || die "configure failed"
emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"