summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-28 03:14:47 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-28 03:14:47 +0000
commitf2c9aec9bc4dba4a6a319c08bb9a2b1c4ab0acb0 (patch)
treefc573cefd6340f44d1c7cb87488b3801d05ce9cf /www-servers
parentUse correct toolchain compiler. (diff)
downloadgentoo-2-f2c9aec9bc4dba4a6a319c08bb9a2b1c4ab0acb0.tar.gz
gentoo-2-f2c9aec9bc4dba4a6a319c08bb9a2b1c4ab0acb0.tar.bz2
gentoo-2-f2c9aec9bc4dba4a6a319c08bb9a2b1c4ab0acb0.zip
introduced support for the examples useflag, also modified the init script to fix #86905
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog7
-rw-r--r--www-servers/tomcat/files/5.0.28/tomcat.init3
-rw-r--r--www-servers/tomcat/tomcat-5.0.28-r2.ebuild14
3 files changed, 15 insertions, 9 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 6c6178cabbf2..65f7e24838cd 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/tomcat
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.23 2005/03/27 17:23:14 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.24 2005/03/28 03:14:47 luckyduck Exp $
+
+ 28 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> files/5.0.28/tomcat.init,
+ tomcat-5.0.28-r2.ebuild:
+ introduced support for the examples useflag, also modified the init script to
+ fix #86905
27 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> tomcat-5.0.28-r2.ebuild:
moved from dev-java/regexp to dev-java/jakarta-regexp dependency. see #71336
diff --git a/www-servers/tomcat/files/5.0.28/tomcat.init b/www-servers/tomcat/files/5.0.28/tomcat.init
index 729884331be0..1de1cc199e2d 100644
--- a/www-servers/tomcat/files/5.0.28/tomcat.init
+++ b/www-servers/tomcat/files/5.0.28/tomcat.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.0.28/tomcat.init,v 1.2 2005/02/13 19:52:06 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.0.28/tomcat.init,v 1.3 2005/03/28 03:14:47 luckyduck Exp $
depend() {
use dns logger mysql postgresql net
@@ -9,6 +9,7 @@ depend() {
start() {
ebegin "Starting Tomcat"
+ cd ${CATALINA_BASE}/webapps
start-stop-daemon --start --quiet --chuid tomcat:tomcat \
--exec ${CATALINA_HOME}/bin/catalina.sh \
-- ${TOMCAT_START}
diff --git a/www-servers/tomcat/tomcat-5.0.28-r2.ebuild b/www-servers/tomcat/tomcat-5.0.28-r2.ebuild
index 5d2c8c67231b..02b5d94a0297 100644
--- a/www-servers/tomcat/tomcat-5.0.28-r2.ebuild
+++ b/www-servers/tomcat/tomcat-5.0.28-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.0.28-r2.ebuild,v 1.3 2005/03/27 17:23:14 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.0.28-r2.ebuild,v 1.4 2005/03/28 03:14:47 luckyduck Exp $
inherit eutils java-pkg
@@ -38,7 +38,7 @@ RDEPEND=">=virtual/jdk-1.4
dev-java/sun-jaf-bin
>=dev-java/xerces-2.6.2-r1
jikes? ( dev-java/jikes )"
-IUSE="doc jikes"
+IUSE="doc examples jikes"
S=${WORKDIR}/jakarta-${P}-src
@@ -186,8 +186,8 @@ src_install() {
cp -ra bin common server shared ${D}/usr/share/${TOMCAT_NAME} || die "failed to copy"
# if the useflag is set, copy over the examples
- if use doc; then
- dodir /var/lib/${TOMCAT_NAME}/default/webapps
+ dodir /var/lib/${TOMCAT_NAME}/default/webapps
+ if use examples; then
cp ../RELEASE-NOTES webapps/ROOT/RELEASE-NOTES.txt
cp -r webapps/{tomcat-docs,jsp-examples,servlets-examples,ROOT,webdav} \
${D}/var/lib/${TOMCAT_NAME}/default/webapps
@@ -199,7 +199,7 @@ src_install() {
dosym /var/tmp/${TOMCAT_NAME}/default /var/lib/${TOMCAT_NAME}/default/temp
dosym /var/run/${TOMCAT_NAME}/default /var/lib/${TOMCAT_NAME}/default/work
- dodoc ${S}/jakarta-tomcat-5/{LICENSE,RELEASE-NOTES,RUNNING.txt}
+ use doc && dodoc ${S}/jakarta-tomcat-5/{LICENSE,RELEASE-NOTES,RUNNING.txt}
fperms 640 /etc/${TOMCAT_NAME}/default/tomcat-users.xml
}
@@ -265,9 +265,9 @@ pkg_postinst() {
einfo " "
einfo " To test Tomcat while it's running, point your web browser to:"
einfo " http://localhost:8080/"
- if ! use doc; then
+ if ! use examples; then
ewarn ""
- ewarn "You do not have the doc USE flag set, examples have NOT been installed."
+ ewarn "You do not have the examples USE flag set, examples have NOT been installed."
ewarn " "
fi
einfo " "