summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-02-01 22:33:00 +0000
committerRémi Cardona <remi@gentoo.org>2009-02-01 22:33:00 +0000
commit9702be6a275962e1c69d16d680643fc657eca603 (patch)
tree8d09658dc4aa62797b451b7876e4ab6fa043f40d /x11-apps/mesa-progs
parentRemoving qt-4.4.0 mask, as this version is no longer in tree (diff)
downloadgentoo-2-9702be6a275962e1c69d16d680643fc657eca603.tar.gz
gentoo-2-9702be6a275962e1c69d16d680643fc657eca603.tar.bz2
gentoo-2-9702be6a275962e1c69d16d680643fc657eca603.zip
x11-apps/mesa-progs: bump to 7.3, copy from the x11 overlay
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-apps/mesa-progs')
-rw-r--r--x11-apps/mesa-progs/ChangeLog7
-rw-r--r--x11-apps/mesa-progs/mesa-progs-7.3.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/x11-apps/mesa-progs/ChangeLog b/x11-apps/mesa-progs/ChangeLog
index cd16a41ad269..db2fb2025cb4 100644
--- a/x11-apps/mesa-progs/ChangeLog
+++ b/x11-apps/mesa-progs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/mesa-progs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/mesa-progs/ChangeLog,v 1.49 2009/01/05 18:05:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/mesa-progs/ChangeLog,v 1.50 2009/02/01 22:33:00 remi Exp $
+
+*mesa-progs-7.3 (01 Feb 2009)
+
+ 01 Feb 2009; Rémi Cardona <remi@gentoo.org> +mesa-progs-7.3.ebuild:
+ bump to 7.3, copy from the x11 overlay
*mesa-progs-7.2 (05 Jan 2009)
diff --git a/x11-apps/mesa-progs/mesa-progs-7.3.ebuild b/x11-apps/mesa-progs/mesa-progs-7.3.ebuild
new file mode 100644
index 000000000000..40652093560d
--- /dev/null
+++ b/x11-apps/mesa-progs/mesa-progs-7.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/mesa-progs/mesa-progs-7.3.ebuild,v 1.1 2009/02/01 22:33:00 remi Exp $
+
+inherit toolchain-funcs
+
+MY_PN="${PN/m/M}"
+MY_PN="${MY_PN/-progs}"
+MY_P="${MY_PN}-${PV/_/-}"
+LIB_P="${MY_PN}Lib-${PV/_/-}"
+PROG_P="${MY_PN}Demos-${PV/_/-}"
+DESCRIPTION="Mesa's OpenGL utility and demo programs (like glxgears)"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+if [[ $PV = *_rc* ]]; then
+ SRC_URI="http://www.mesa3d.org/beta/${LIB_P}.tar.gz
+ http://www.mesa3d.org/beta/${PROG_P}.tar.gz"
+elif [[ $PV = 9999 ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/mesa3d/${LIB_P}.tar.bz2
+ mirror://sourceforge/mesa3d/${PROG_P}.tar.bz2"
+fi
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="virtual/glut
+ virtual/opengl
+ virtual/glu"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if [[ ${KERNEL} == "FreeBSD" ]]; then
+ CONFIG="freebsd"
+ elif use x86; then
+ CONFIG="linux-dri-x86"
+ elif use amd64; then
+ CONFIG="linux-dri-x86-64"
+ elif use ppc; then
+ CONFIG="linux-dri-ppc"
+ else
+ CONFIG="linux-dri"
+ fi
+}
+
+src_unpack() {
+ HOSTCONF="${S}/configs/${CONFIG}"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Kill this; we don't want /usr/X11R6/lib ever to be searched in this
+ # build.
+ echo "EXTRA_LIB_PATH =" >> ${HOSTCONF}
+
+ echo "OPT_FLAGS = ${CFLAGS}" >> ${HOSTCONF}
+ echo "CC = $(tc-getCC)" >> ${HOSTCONF}
+ echo "CXX = $(tc-getCXX)" >> ${HOSTCONF}
+
+ # Just executables here, no need to compile with -fPIC
+ echo "PIC_FLAGS =" >> ${HOSTCONF}
+}
+
+src_compile() {
+ cd "${S}"/configs
+ ln -s ${CONFIG} current
+
+ cd "${S}"/progs/xdemos
+
+ emake glxinfo || die "glxinfo failed"
+ emake glxgears || die "glxgears failed"
+}
+
+src_install() {
+ dobin "${S}"/progs/xdemos/{glxgears,glxinfo} || die
+}