summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
commit57fb94ba97fd17987ae03bea4bd04417b795d84b (patch)
tree9bfd00b09ca8ce22f5f0c789638e86d6e99bbc25 /x11-apps/xclipboard
parentversion bump (diff)
downloadgentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.gz
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.bz2
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-apps/xclipboard')
-rw-r--r--x11-apps/xclipboard/ChangeLog10
-rw-r--r--x11-apps/xclipboard/Manifest2
-rw-r--r--x11-apps/xclipboard/files/digest-xclipboard-0.99.01
-rw-r--r--x11-apps/xclipboard/xclipboard-0.99.0.ebuild22
4 files changed, 35 insertions, 0 deletions
diff --git a/x11-apps/xclipboard/ChangeLog b/x11-apps/xclipboard/ChangeLog
new file mode 100644
index 000000000000..0b295d8faad0
--- /dev/null
+++ b/x11-apps/xclipboard/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/xclipboard
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclipboard/ChangeLog,v 1.1 2005/08/08 06:28:10 spyderous Exp $
+
+*xclipboard-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +xclipboard-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xclipboard/Manifest b/x11-apps/xclipboard/Manifest
new file mode 100644
index 000000000000..4b03161eaa6e
--- /dev/null
+++ b/x11-apps/xclipboard/Manifest
@@ -0,0 +1,2 @@
+MD5 3778ce451ef6b9d224bb37c61de8356f xclipboard-0.99.0.ebuild 497
+MD5 3f52e540fb44a4472080d912654e3081 files/digest-xclipboard-0.99.0 69
diff --git a/x11-apps/xclipboard/files/digest-xclipboard-0.99.0 b/x11-apps/xclipboard/files/digest-xclipboard-0.99.0
new file mode 100644
index 000000000000..1f660b3fdf37
--- /dev/null
+++ b/x11-apps/xclipboard/files/digest-xclipboard-0.99.0
@@ -0,0 +1 @@
+MD5 408baa2961f6fc020ff67f4d9c76fe73 xclipboard-0.99.0.tar.bz2 60102
diff --git a/x11-apps/xclipboard/xclipboard-0.99.0.ebuild b/x11-apps/xclipboard/xclipboard-0.99.0.ebuild
new file mode 100644
index 000000000000..673a0c0a7fd7
--- /dev/null
+++ b/x11-apps/xclipboard/xclipboard-0.99.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclipboard/xclipboard-0.99.0.ebuild,v 1.1 2005/08/08 06:28:10 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xclipboard application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}