summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-01-22 17:56:44 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-01-22 17:56:44 +0000
commit1f13b7cc2887970b29a082e031ceb8726c2b12b6 (patch)
tree329fab44c52eac40a96eb1e19c515d0d0821bf09 /x11-apps
parentStable on amd64 wrt bug #352409 (diff)
downloadgentoo-2-1f13b7cc2887970b29a082e031ceb8726c2b12b6.tar.gz
gentoo-2-1f13b7cc2887970b29a082e031ceb8726c2b12b6.tar.bz2
gentoo-2-1f13b7cc2887970b29a082e031ceb8726c2b12b6.zip
revision bump, this is the first version supporting lxdm, reset KEYWORDS to ~arch
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/xinit-1.3.0-r2.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 6decc9c5216b..750f3cb9cb5d 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.200 2011/01/22 15:35:49 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.201 2011/01/22 17:56:44 lxnay Exp $
+
+*xinit-1.3.0-r2 (22 Jan 2011)
+
+ 22 Jan 2011; Fabio Erculiani <lxnay@gentoo.org> +xinit-1.3.0-r2.ebuild:
+ revision bump, this is the first version supporting lxdm, reset KEYWORDS
+ to ~arch
22 Jan 2011; Fabio Erculiani <lxnay@gentoo.org> files/startDM.sh:
add lxdm support (changes required in order to load lxdm with
diff --git a/x11-apps/xinit/xinit-1.3.0-r2.ebuild b/x11-apps/xinit/xinit-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..98efd21e888b
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.3.0-r2.ebuild,v 1.1 2011/01/22 17:56:44 lxnay Exp $
+
+EAPI=3
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-Gentoo-customizations.patch"
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ CONFIGURE_OPTIONS="--with-xinitdir=/etc/X11/xinit"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xserverrc || die
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/00-xhost"
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}