summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-02 23:35:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-02 23:35:33 +0000
commit771fc55578ae703d32535fdc6bbc391896d3456b (patch)
tree5a5098338c2f42b1bfdb1e69ca8696a68f2a0b56 /x11-apps
parentFix default xserverrc to accept parameters wrt #343911 by "Faustus". (diff)
downloadgentoo-2-771fc55578ae703d32535fdc6bbc391896d3456b.tar.gz
gentoo-2-771fc55578ae703d32535fdc6bbc391896d3456b.tar.bz2
gentoo-2-771fc55578ae703d32535fdc6bbc391896d3456b.zip
revbump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/xinit-1.2.0-r4.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index aab2fc8e77ac..64cd555b503b 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.184 2010/11/02 23:27:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.185 2010/11/02 23:35:33 ssuominen Exp $
+
+*xinit-1.2.0-r4 (02 Nov 2010)
+
+ 02 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xinit-1.2.0-r4.ebuild:
+ Revision bump for "Fix default xserverrc to accept parameters".
*xinit-1.3.0-r1 (02 Nov 2010)
diff --git a/x11-apps/xinit/xinit-1.2.0-r4.ebuild b/x11-apps/xinit/xinit-1.2.0-r4.ebuild
new file mode 100644
index 000000000000..18ac24eb2cf1
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.2.0-r4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.2.0-r4.ebuild,v 1.1 2010/11/02 23:35:33 ssuominen Exp $
+
+EAPI="2"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+minimal pam"
+
+RDEPEND="
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-Gentoo-specific-customizations.patch"
+)
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="--with-xinitdir=/etc/X11/xinit"
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xserverrc || die
+ newinitd "${FILESDIR}"/xdm.initd-4 xdm || die
+ newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup || die
+ newconfd "${FILESDIR}"/xdm.confd-2 xdm || die
+ newpamd "${FILESDIR}"/xserver.pamd xserver
+ dodir /etc/X11/xinit/xinitrc.d
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/00-xhost"
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}