summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-08 18:26:50 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-08 18:26:50 +0000
commita646d0f79985b6f6ad14b371c65990202bff296b (patch)
tree5b03596ea432f69b3d89498b9c3c097c439ce4af /x11-apps
parentnarrow xinit mask to broken version (diff)
downloadgentoo-2-a646d0f79985b6f6ad14b371c65990202bff296b.tar.gz
gentoo-2-a646d0f79985b6f6ad14b371c65990202bff296b.tar.bz2
gentoo-2-a646d0f79985b6f6ad14b371c65990202bff296b.zip
conditionally revert upstream patch that broke startx on non-systemd systems, bug #526802.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog9
-rw-r--r--x11-apps/xinit/files/xinit-1.3.4-startx-current-vt.patch21
-rw-r--r--x11-apps/xinit/xinit-1.3.4-r1.ebuild75
3 files changed, 104 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index a7ba75138547..785d492b39d3 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.257 2015/01/03 14:49:32 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.258 2015/02/08 18:26:50 chithanh Exp $
+
+*xinit-1.3.4-r1 (08 Feb 2015)
+
+ 08 Feb 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xinit-1.3.4-startx-current-vt.patch, +xinit-1.3.4-r1.ebuild:
+ conditionally revert upstream patch that broke startx on non-systemd systems,
+ bug #526802.
03 Jan 2015; Benda Xu <heroxbd@gentoo.org> xinit-1.3.3-r1.ebuild:
xinitdir handling for Prefix.
diff --git a/x11-apps/xinit/files/xinit-1.3.4-startx-current-vt.patch b/x11-apps/xinit/files/xinit-1.3.4-startx-current-vt.patch
new file mode 100644
index 000000000000..362b420cfc8f
--- /dev/null
+++ b/x11-apps/xinit/files/xinit-1.3.4-startx-current-vt.patch
@@ -0,0 +1,21 @@
+diff -ur a/startx.cpp b/startx.cpp
+--- a/startx.cpp 2014-09-11 19:31:42.000000000 +0200
++++ b/startx.cpp 2015-02-08 19:09:56.416428623 +0100
+@@ -188,17 +188,6 @@
+ if [ x"$server" = x ]; then
+ server=$defaultserver
+
+-#ifdef __linux__
+- XCOMM When starting the defaultserver start X on the current tty to avoid
+- XCOMM the startx session being seen as inactive:
+- XCOMM "https://bugzilla.redhat.com/show_bug.cgi?id=806491"
+- tty=$(tty)
+- if expr match "$tty" '^/dev/tty[0-9]\+$' > /dev/null; then
+- tty_num=$(echo "$tty" | grep -oE '[0-9]+$')
+- vtarg="vt$tty_num"
+- fi
+-#endif
+-
+ XCOMM For compatibility reasons, only use xserverrc if there were no server command line arguments
+ if [ x"$serverargs" = x -a x"$display" = x ]; then
+ if [ -f "$userserverrc" ]; then
diff --git a/x11-apps/xinit/xinit-1.3.4-r1.ebuild b/x11-apps/xinit/xinit-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..5d0f1e904772
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.4-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.3.4-r1.ebuild,v 1.1 2015/02/08 18:26:50 chithanh Exp $
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal systemd"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+)
+
+src_prepare() {
+ # this patch breaks startx on non-systemd systems, bug #526802
+ if use !systemd; then
+ PATCHES+=( "${FILESDIR}"/${PN}-1.3.4-startx-current-vt.patch )
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.1 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}