summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-03-11 02:01:24 +0000
committerRoy Marples <uberlord@gentoo.org>2007-03-11 02:01:24 +0000
commitadfb588a92c4724d13169018d563a430e1d43d6f (patch)
tree462accdf91c31d1424483a3a0ac05b3ce5a8be65 /x11-apps
parent Don't copy the daemons directory across when upgrading as it just won't work (diff)
downloadgentoo-2-adfb588a92c4724d13169018d563a430e1d43d6f.tar.gz
gentoo-2-adfb588a92c4724d13169018d563a430e1d43d6f.tar.bz2
gentoo-2-adfb588a92c4724d13169018d563a430e1d43d6f.zip
Work better with non bash shells.
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog5
-rw-r--r--x11-apps/xinit/files/startDM.sh37
2 files changed, 19 insertions, 23 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index c99ff72f1284..aacc0cfcb5ac 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.76 2007/03/04 16:28:36 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.77 2007/03/11 02:01:24 uberlord Exp $
+
+ 11 Mar 2007; Roy Marples <uberlord@gentoo.org> files/startDM.sh:
+ Work better with non bash shells.
04 Mar 2007; Joshua Baergen <joshuabaergen@gentoo.org>
xinit-1.0.2-r6.ebuild, xinit-1.0.3.ebuild, xinit-1.0.3-r1.ebuild:
diff --git a/x11-apps/xinit/files/startDM.sh b/x11-apps/xinit/files/startDM.sh
index f308271a1146..d2132348372d 100644
--- a/x11-apps/xinit/files/startDM.sh
+++ b/x11-apps/xinit/files/startDM.sh
@@ -1,35 +1,28 @@
-#!/bin/bash
+#!/bin/sh
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/startDM.sh,v 1.2 2006/07/01 00:48:30 vapier Exp $
-#
-# Author: Martin Schlemmer <azarah@gentoo.org>
-
-source /etc/init.d/functions.sh
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/startDM.sh,v 1.3 2007/03/11 02:01:24 uberlord Exp $
# We need to source /etc/profile for stuff like $LANG to work
# bug #10190.
-source /etc/profile
+. /etc/profile
+
+. /etc/init.d/functions.sh
+
+# baselayout-1 compat
+if ! type get_options >/dev/null 2>/dev/null ; then
+ [ -r "${svclib}"/sh/rc-services.sh ] && . "${svclib}"/sh/rc-services.sh
+fi
# Great new Gnome2 feature, AA
# We enable this by default
export GDK_USE_XFT=1
-if [[ -e ${svcdir}/options/xdm/service ]] ; then
- retval=0
- EXE=$(<"${svcdir}"/options/xdm/service)
-
- /sbin/start-stop-daemon --start --quiet --exec ${EXE}
- retval=$?
- # Fix bug #26125 for slower systems
- wait; sleep 2
+export SVCNAME=xdm
+EXEC="$(get_options service)"
+NAME="$(get_options name)"
- if [[ ${retval} -ne 0 ]] ; then
- # there was a error running the DM
- einfo "ERROR: could not start the Display Manager..."
- # make sure we do not have a misbehaving DM
- killall -9 ${EXE##*/}
- fi
-fi
+start-stop-daemon --start --exec ${EXEC} ${NAME:+--name }${NAME} || \
+eerror "ERROR: could not start the Display Manager"
# vim:ts=4