summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:42:01 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:42:01 +0000
commitde84ba1467916026e8f3e98cae92afbc8f08cf58 (patch)
tree5ce608a6701cc2ca26b968e0c8a6f3749dd11aed /x11-apps
parentVersion bump. Includes a Cygwin build fix. (diff)
downloadgentoo-2-de84ba1467916026e8f3e98cae92afbc8f08cf58.tar.gz
gentoo-2-de84ba1467916026e8f3e98cae92afbc8f08cf58.tar.bz2
gentoo-2-de84ba1467916026e8f3e98cae92afbc8f08cf58.zip
Version bump. Adds an extra check that avoids a memory leak and NULL
dereference. (Portage version: 2.1_pre10)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xfs/ChangeLog8
-rw-r--r--x11-apps/xfs/files/digest-xfs-1.0.23
-rw-r--r--x11-apps/xfs/xfs-1.0.2.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-apps/xfs/ChangeLog b/x11-apps/xfs/ChangeLog
index 6d38dfc49c9d..fd827f488e7e 100644
--- a/x11-apps/xfs/ChangeLog
+++ b/x11-apps/xfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xfs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.18 2006/04/21 20:36:57 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.19 2006/04/29 16:42:01 joshuabaergen Exp $
+
+*xfs-1.0.2 (29 Apr 2006)
+
+ 29 Apr 2006; Joshua Baergen <joshuabaergen@gentoo.org> +xfs-1.0.2.ebuild:
+ Version bump. Adds an extra check that avoids a memory leak and NULL
+ dereference.
21 Apr 2006; Joseph Jezak <josejx@gentoo.org> xfs-1.0.1.ebuild:
Marked ~ppc.
diff --git a/x11-apps/xfs/files/digest-xfs-1.0.2 b/x11-apps/xfs/files/digest-xfs-1.0.2
new file mode 100644
index 000000000000..e3919af8a42a
--- /dev/null
+++ b/x11-apps/xfs/files/digest-xfs-1.0.2
@@ -0,0 +1,3 @@
+MD5 6745fe95dd43863c60f6583500f0e115 xfs-1.0.2.tar.bz2 145212
+RMD160 26a1da3822829ff92ba472d89069e12c5530beb2 xfs-1.0.2.tar.bz2 145212
+SHA256 6e5fb04920a3649565e41302b17306e5c40c9c5aa7de446e2db523c3bab92b44 xfs-1.0.2.tar.bz2 145212
diff --git a/x11-apps/xfs/xfs-1.0.2.ebuild b/x11-apps/xfs/xfs-1.0.2.ebuild
new file mode 100644
index 000000000000..83a6d177bdd2
--- /dev/null
+++ b/x11-apps/xfs/xfs-1.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/xfs-1.0.2.ebuild,v 1.1 2006/04/29 16:42:01 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org Font Server"
+
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+RDEPEND="x11-apps/ttmkfdir
+ x11-libs/libFS
+ x11-libs/libXfont"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6) --libdir=/etc"
+
+pkg_setup() {
+ enewgroup xfs 33
+ enewuser xfs 33 -1 /etc/X11/fs xfs
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^configdir =.*:configdir = \$(sysconfdir)/X11/fs:g" \
+ "${S}"/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+
+ insinto /etc/X11/fs
+ newins "${FILESDIR}"/xfs.config config
+ newinitd "${FILESDIR}"/xfs.start xfs
+ newconfd "${FILESDIR}"/xfs.conf.d xfs
+}