summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-01-20 18:07:22 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-01-20 18:07:22 +0000
commiteb1fcf629a278f875d74fdbd817edcf1995d7e21 (patch)
tree60c3c3f947cb1335d094c41ce59cd3ea6fb77d86 /x11-apps
parentAdd dev-utl/gtk-doc dependency (diff)
downloadgentoo-2-eb1fcf629a278f875d74fdbd817edcf1995d7e21.tar.gz
gentoo-2-eb1fcf629a278f875d74fdbd817edcf1995d7e21.tar.bz2
gentoo-2-eb1fcf629a278f875d74fdbd817edcf1995d7e21.zip
new ebuild, close bug #348305
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/whyteboard/ChangeLog10
-rw-r--r--x11-apps/whyteboard/files/whyteboard.desktop13
-rw-r--r--x11-apps/whyteboard/files/whyteboard.pngbin0 -> 7601 bytes
-rw-r--r--x11-apps/whyteboard/metadata.xml31
-rw-r--r--x11-apps/whyteboard/whyteboard-0.41.1.ebuild54
5 files changed, 108 insertions, 0 deletions
diff --git a/x11-apps/whyteboard/ChangeLog b/x11-apps/whyteboard/ChangeLog
new file mode 100644
index 000000000000..8b0577e1422e
--- /dev/null
+++ b/x11-apps/whyteboard/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/whyteboard
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/whyteboard/ChangeLog,v 1.1 2011/01/20 18:07:22 lxnay Exp $
+
+*whyteboard-0.41.1 (20 Jan 2011)
+
+ 20 Jan 2011; Fabio Erculiani <lxnay@gentoo.org> +whyteboard-0.41.1.ebuild,
+ +files/whyteboard.desktop, +files/whyteboard.png, +metadata.xml:
+ new ebuild, close bug #348305
+
diff --git a/x11-apps/whyteboard/files/whyteboard.desktop b/x11-apps/whyteboard/files/whyteboard.desktop
new file mode 100644
index 000000000000..958e63690082
--- /dev/null
+++ b/x11-apps/whyteboard/files/whyteboard.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Type=Application
+Name=Whyteboard
+GenericName=Panting App
+GenericName[it]=lavagna
+Comment=Simple whiteboard and PDF annotator
+Exec=whyteboard %U
+TryExec=whyteboard
+Icon=/usr/share/pixmaps/whyteboard.png
+Terminal=false
+Categories=GNOME;GTK;Utility;
+StartupNotify=true
+MimeType=image/png;image/svg+xml;
diff --git a/x11-apps/whyteboard/files/whyteboard.png b/x11-apps/whyteboard/files/whyteboard.png
new file mode 100644
index 000000000000..8d430b7c1e94
--- /dev/null
+++ b/x11-apps/whyteboard/files/whyteboard.png
Binary files differ
diff --git a/x11-apps/whyteboard/metadata.xml b/x11-apps/whyteboard/metadata.xml
new file mode 100644
index 000000000000..0d01598caae7
--- /dev/null
+++ b/x11-apps/whyteboard/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ <description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<maintainer>
+ <email>ziapannocchia@gmail.com</email>
+ <name>Marco Clocchiatti</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<longdescription lang="en">
+A simple image, PDF and postscript file annotator.
+</longdescription>
+<maintainer>
+ <email>ziapanocchia@gmail.com</email>
+ <name>Marco Clocchiatti</name>
+</maintainer>
+<upstream>
+ <maintainer status="active" >
+ <email></email>
+ <name>Steven Sproat</name>
+ </maintainer>
+ <remote-id type="google-code">http://whyteboard.org/</remote-id>
+</upstream>
+<use>
+</use>
+</pkgmetadata>
diff --git a/x11-apps/whyteboard/whyteboard-0.41.1.ebuild b/x11-apps/whyteboard/whyteboard-0.41.1.ebuild
new file mode 100644
index 000000000000..d62c108ea523
--- /dev/null
+++ b/x11-apps/whyteboard/whyteboard-0.41.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/whyteboard/whyteboard-0.41.1.ebuild,v 1.1 2011/01/20 18:07:22 lxnay Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2" # Upstream doesn't support Python 3.x
+
+inherit eutils python multilib
+
+DESCRIPTION="A simple image, PDF and postscript file annotator."
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+HOMEPAGE="http://code.google.com/p/whyteboard"
+SRC_URI="http://whyteboard.googlecode.com/files/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${DEPEND}
+ dev-python/wxpython
+ media-gfx/imagemagick"
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/applications
+ dodir /usr/share/pixmaps
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}/${PN}.png" || die
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop" || die
+
+ dodoc CHANGELOG.txt DEVELOPING.txt README.txt TODO.txt || die
+
+ local appdir="$(python_get_sitedir)/${PN}"
+ dodir "${appdir}"
+ insinto "${appdir}"
+ doins -r images 'locale' "${PN}" "${PN}-help" "${PN}.py" || die
+
+ cat >> "${T}/${PN}" <<- EOF
+ #!/bin/sh
+ exec $(PYTHON) -O "$(python_get_sitedir)/${PN}/${PN}.py"
+ EOF
+ exeinto /usr/bin
+ doexe "${T}/${PN}" || die
+}
+
+pkg_preinst() {
+ echo
+ elog "This application is very experimental and some features"
+ elog "are not yet implemented, however you can live with it"
+ echo
+}