summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-02-18 20:02:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-02-18 20:02:05 +0000
commitfed634c253706e3055c76df55b4b39fa12cab987 (patch)
treeab466713491158c2b5151a62b828856f2cdb62bc /x11-apps
parentVersion bump. (diff)
downloadgentoo-2-fed634c253706e3055c76df55b4b39fa12cab987.tar.gz
gentoo-2-fed634c253706e3055c76df55b4b39fa12cab987.tar.bz2
gentoo-2-fed634c253706e3055c76df55b4b39fa12cab987.zip
Version bump.
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xsm/ChangeLog11
-rw-r--r--x11-apps/xsm/xsm-1.0.3.ebuild33
2 files changed, 41 insertions, 3 deletions
diff --git a/x11-apps/xsm/ChangeLog b/x11-apps/xsm/ChangeLog
index 4bd186c44d8d..4f8caeec9a27 100644
--- a/x11-apps/xsm/ChangeLog
+++ b/x11-apps/xsm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xsm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xsm/ChangeLog,v 1.34 2012/05/11 03:06:45 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xsm/ChangeLog,v 1.35 2013/02/18 20:02:05 chithanh Exp $
+
+*xsm-1.0.3 (18 Feb 2013)
+
+ 18 Feb 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xsm-1.0.3.ebuild:
+ Version bump.
11 May 2012; Alexis Ballier <aballier@gentoo.org> xsm-1.0.2.ebuild:
keyword ~amd64-fbsd
@@ -122,4 +128,3 @@
08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +xsm-0.99.0.ebuild:
Initial commit for modular X.
-
diff --git a/x11-apps/xsm/xsm-1.0.3.ebuild b/x11-apps/xsm/xsm-1.0.3.ebuild
new file mode 100644
index 000000000000..36f430a66e42
--- /dev/null
+++ b/x11-apps/xsm/xsm-1.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xsm/xsm-1.0.3.ebuild,v 1.1 2013/02/18 20:02:05 chithanh Exp $
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Session Manager"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="rsh"
+RDEPEND="x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ rsh? ( net-misc/netkit-rsh )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
+ local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
+ if [[ -L ${XSMPATH} ]]; then
+ einfo "Removing symlink ${XSMPATH}"
+ rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
+ fi
+ xorg-2_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
+ xorg-2_src_configure
+}