summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2008-09-13 01:12:14 +0000
committerBryan Stine <battousai@gentoo.org>2008-09-13 01:12:14 +0000
commit214bb752d603bda8dc5ca5f3e993dcdd8f5724ae (patch)
tree249058f073b711f27aaaaa236d51275a299b2c00 /x11-base/x11-drm
parentfix url typo (diff)
downloadgentoo-2-214bb752d603bda8dc5ca5f3e993dcdd8f5724ae.tar.gz
gentoo-2-214bb752d603bda8dc5ca5f3e993dcdd8f5724ae.tar.bz2
gentoo-2-214bb752d603bda8dc5ca5f3e993dcdd8f5724ae.zip
20060608(-r1) patchball 0.4. Remove modules.d for all ebuilds. Fixes: #165553, #204985, #214035, #218419.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'x11-base/x11-drm')
-rw-r--r--x11-base/x11-drm/ChangeLog9
-rw-r--r--x11-base/x11-drm/files/modules.d-x11-drm3
-rw-r--r--x11-base/x11-drm/x11-drm-20060608-r1.ebuild32
-rw-r--r--x11-base/x11-drm/x11-drm-20060608.ebuild32
-rw-r--r--x11-base/x11-drm/x11-drm-20070314.ebuild26
-rw-r--r--x11-base/x11-drm/x11-drm-20071019.ebuild26
-rw-r--r--x11-base/x11-drm/x11-drm-20080710.ebuild7
7 files changed, 77 insertions, 58 deletions
diff --git a/x11-base/x11-drm/ChangeLog b/x11-base/x11-drm/ChangeLog
index 271ecb0e02bd..d5ce7183b619 100644
--- a/x11-base/x11-drm/ChangeLog
+++ b/x11-base/x11-drm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-base/x11-drm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.60 2008/09/12 21:30:21 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.61 2008/09/13 01:12:14 battousai Exp $
+
+ 13 Sep 2008; Bryan D. Stine <battousai@gentoo.org>
+ -files/modules.d-x11-drm, x11-drm-20060608.ebuild,
+ x11-drm-20060608-r1.ebuild, x11-drm-20070314.ebuild,
+ x11-drm-20071019.ebuild, x11-drm-20080710.ebuild:
+ Bump 20060608 and -r1 to 0.4 patchball, fixing bugs #165553, #218419. Pull
+ modules.d file from all ebuilds, fixing bug #214035.
12 Sep 2008; Bryan D. Stine <battousai@gentoo.org>
x11-drm-20070314.ebuild, x11-drm-20080710.ebuild:
diff --git a/x11-base/x11-drm/files/modules.d-x11-drm b/x11-base/x11-drm/files/modules.d-x11-drm
deleted file mode 100644
index aa6e850dded4..000000000000
--- a/x11-base/x11-drm/files/modules.d-x11-drm
+++ /dev/null
@@ -1,3 +0,0 @@
-keep
-path[%PN%]=/lib/modules/%KV%/%PN%
-
diff --git a/x11-base/x11-drm/x11-drm-20060608-r1.ebuild b/x11-base/x11-drm/x11-drm-20060608-r1.ebuild
index 2cb33d96683e..58e8dd92bc44 100644
--- a/x11-base/x11-drm/x11-drm-20060608-r1.ebuild
+++ b/x11-base/x11-drm/x11-drm-20060608-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608-r1.ebuild,v 1.8 2008/07/11 02:51:08 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608-r1.ebuild,v 1.9 2008/09/13 01:12:14 battousai Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.7"
@@ -26,7 +26,7 @@ IUSE="${IUSE_VIDEO_CARDS} kernel_FreeBSD kernel_linux"
RESTRICT="strip"
S="${WORKDIR}/drm"
-PATCHVER="0.3"
+PATCHVER="0.4"
PATCHDIR="${WORKDIR}/patch"
EXCLUDED="${WORKDIR}/excluded"
@@ -129,20 +129,22 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- linux-mod_pkg_setup
-
if kernel_is 2 6
then
- linux_chkconfig_builtin "DRM" && \
- die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
-
- CONFIG_CHECK="AGP"
+ CONFIG_CHECK="!DRM AGP"
+ ERROR_DRM="Please disable the Direct Rendering Manager in the kernel config. (CONFIG_DRM)"
ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
+
+ kernel_is ge 2 6 25 && \
+ CONFIG_CHECK="${CONFIG_CHECK} ~UNUSED_SYMBOLS" \
+ ERROR_UNUSED_SYMBOLS="Please enable unused/obsolete exported symbols in your kernel config (CONFIG_UNUSED_SYMBOLS). These modules will not load otherwise."
elif kernel_is 2 4
then
CONFIG_CHECK="DRM"
ERROR_DRM="Please enable DRM support in your kernel configuration. (CONFIG_DRM = y or m)."
fi
+
+ linux-mod_pkg_setup
fi
}
@@ -315,11 +317,6 @@ src_install_linux() {
# Strip binaries, leaving /lib/modules untouched (bug #24415)
strip_bins \/lib\/modules
-
- # Yoinked from the sys-apps/touchpad ebuild. Thanks to whoever made this.
- keepdir /etc/modules.d
- sed 's:%PN%:'${PN}':g' "${FILESDIR}"/modules.d-${PN} > "${D}"/etc/modules.d/${PN}
- sed -i 's:%KV%:'${KV_FULL}':g' "${D}"/etc/modules.d/${PN}
}
src_install_freebsd() {
@@ -338,5 +335,14 @@ pkg_postinst_os() {
if use kernel_linux
then
linux-mod_pkg_postinst
+
+ elog "Having in-kernel DRM modules installed can prevent x11-drm modules from being"
+ elog "loaded. It can also lead to unknown symbols in x11-drm modules, which would"
+ elog "be seen during the installation. If you experience any of those problems,"
+ elog "please ensure that the in-kernel DRM modules are not installed."
+ elog "This can be done with the following:"
+ elog " cd ${KERNEL_DIR}"
+ elog " make modules modules_install"
+ elog "This should allow the x11-drm modules to load and function normally."
fi
}
diff --git a/x11-base/x11-drm/x11-drm-20060608.ebuild b/x11-base/x11-drm/x11-drm-20060608.ebuild
index 315609b07087..a911b697bdbd 100644
--- a/x11-base/x11-drm/x11-drm-20060608.ebuild
+++ b/x11-base/x11-drm/x11-drm-20060608.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608.ebuild,v 1.13 2007/10/09 07:36:00 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608.ebuild,v 1.14 2008/09/13 01:12:14 battousai Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.7"
@@ -26,7 +26,7 @@ IUSE="${IUSE_VIDEO_CARDS}"
RESTRICT="strip"
S="${WORKDIR}/drm"
-PATCHVER="0.3"
+PATCHVER="0.4"
PATCHDIR="${WORKDIR}/patch"
EXCLUDED="${WORKDIR}/excluded"
@@ -43,19 +43,21 @@ DEPEND="virtual/linux-sources"
RDEPEND=""
pkg_setup() {
- linux-mod_pkg_setup
-
if kernel_is 2 6 ; then
- linux_chkconfig_builtin "DRM" && \
- die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
- CONFIG_CHECK="AGP"
+ CONFIG_CHECK="!DRM AGP"
+ ERROR_DRM="Please disable the Direct Rendering Manager in the kernel config. (CONFIG_DRM)"
ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
+ kernel_is ge 2 6 25 && \
+ CONFIG_CHECK="${CONFIG_CHECK} ~UNUSED_SYMBOLS" \
+ ERROR_UNUSED_SYMBOLS="Please enable unused/obsolete exported symbols in your kernel config (CONFIG_UNUSED_SYMBOLS). These modules will not load otherwise."
elif kernel_is 2 4 ; then
CONFIG_CHECK="DRM"
ERROR_DRM="Please enable DRM support in your kernel configuration. (CONFIG_DRM = y or m)."
fi
+ linux-mod_pkg_setup
+
# Set video cards to build for.
set_vidcards
@@ -137,11 +139,6 @@ src_install() {
# Strip binaries, leaving /lib/modules untouched (bug #24415)
strip_bins \/lib\/modules
-
- # Yoinked from the sys-apps/touchpad ebuild. Thanks to whoever made this.
- keepdir /etc/modules.d
- sed 's:%PN%:'${PN}':g' "${FILESDIR}"/modules.d-${PN} > "${D}"/etc/modules.d/${PN}
- sed -i 's:%KV%:'${KV_FULL}':g' "${D}"/etc/modules.d/${PN}
}
pkg_postinst() {
@@ -160,6 +157,15 @@ pkg_postinst() {
fi
linux-mod_pkg_postinst
+
+ elog "Having in-kernel DRM modules installed can prevent x11-drm modules from being"
+ elog "loaded. It can also lead to unknown symbols in x11-drm modules, which would"
+ elog "be seen during the installation. If you experience any of those problems,"
+ elog "please ensure that the in-kernel DRM modules are not installed."
+ elog "This can be done with the following:"
+ elog " cd ${KERNEL_DIR}"
+ elog " make modules modules_install"
+ elog "This should allow the x11-drm modules to load and function normally."
}
# Functions used above are defined below:
diff --git a/x11-base/x11-drm/x11-drm-20070314.ebuild b/x11-base/x11-drm/x11-drm-20070314.ebuild
index 28b7e122c2a6..87bca0d0dc6b 100644
--- a/x11-base/x11-drm/x11-drm-20070314.ebuild
+++ b/x11-base/x11-drm/x11-drm-20070314.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.7 2008/09/12 21:30:21 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.8 2008/09/13 01:12:14 battousai Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.7"
@@ -128,8 +128,6 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- linux-mod_pkg_setup
-
if kernel_is 2 4
then
eerror "Upstream support for 2.4 kernels has been removed, so this package will no"
@@ -137,11 +135,11 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- linux_chkconfig_builtin "DRM" && \
- die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
-
- CONFIG_CHECK="AGP"
+ CONFIG_CHECK="!DRM AGP"
+ ERROR_DRM="Please disable the Direct Rendering Manager in the kernel config. (CONFIG_DRM)"
ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
+
+ linux-mod_pkg_setup
fi
}
@@ -309,11 +307,6 @@ src_install_linux() {
# Strip binaries, leaving /lib/modules untouched (bug #24415)
strip_bins \/lib\/modules
-
- # Yoinked from the sys-apps/touchpad ebuild. Thanks to whoever made this.
- keepdir /etc/modules.d
- sed 's:%PN%:'${PN}':g' "${FILESDIR}"/modules.d-${PN} > "${D}"/etc/modules.d/${PN}
- sed -i 's:%KV%:'${KV_FULL}':g' "${D}"/etc/modules.d/${PN}
}
src_install_freebsd() {
@@ -332,5 +325,14 @@ pkg_postinst_os() {
if use kernel_linux
then
linux-mod_pkg_postinst
+
+ elog "Having in-kernel DRM modules installed can prevent x11-drm modules from being"
+ elog "loaded. It can also lead to unknown symbols in x11-drm modules, which would"
+ elog "be seen during the installation. If you experience any of those problems,"
+ elog "please ensure that the in-kernel DRM modules are not installed."
+ elog "This can be done with the following:"
+ elog " cd ${KERNEL_DIR}"
+ elog " make modules modules_install"
+ elog "This should allow the x11-drm modules to load and function normally."
fi
}
diff --git a/x11-base/x11-drm/x11-drm-20071019.ebuild b/x11-base/x11-drm/x11-drm-20071019.ebuild
index c455b734a511..88a51024ee41 100644
--- a/x11-base/x11-drm/x11-drm-20071019.ebuild
+++ b/x11-base/x11-drm/x11-drm-20071019.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20071019.ebuild,v 1.2 2008/07/11 02:51:08 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20071019.ebuild,v 1.3 2008/09/13 01:12:14 battousai Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.7"
@@ -128,8 +128,6 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- linux-mod_pkg_setup
-
if kernel_is 2 4
then
eerror "Upstream support for 2.4 kernels has been removed, so this package will no"
@@ -137,11 +135,11 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- linux_chkconfig_builtin "DRM" && \
- die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
-
- CONFIG_CHECK="AGP"
+ CONFIG_CHECK="!DRM AGP"
+ ERROR_DRM="Please disable the Direct Rendering Manager in the kernel config. (CONFIG_DRM)"
ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
+
+ linux-mod_pkg_setup
fi
}
@@ -309,11 +307,6 @@ src_install_linux() {
# Strip binaries, leaving /lib/modules untouched (bug #24415)
strip_bins \/lib\/modules
-
- # Yoinked from the sys-apps/touchpad ebuild. Thanks to whoever made this.
- keepdir /etc/modules.d
- sed 's:%PN%:'${PN}':g' "${FILESDIR}"/modules.d-${PN} > "${D}"/etc/modules.d/${PN}
- sed -i 's:%KV%:'${KV_FULL}':g' "${D}"/etc/modules.d/${PN}
}
src_install_freebsd() {
@@ -332,5 +325,14 @@ pkg_postinst_os() {
if use kernel_linux
then
linux-mod_pkg_postinst
+
+ elog "Having in-kernel DRM modules installed can prevent x11-drm modules from being"
+ elog "loaded. It can also lead to unknown symbols in x11-drm modules, which would"
+ elog "be seen during the installation. If you experience any of those problems,"
+ elog "please ensure that the in-kernel DRM modules are not installed."
+ elog "This can be done with the following:"
+ elog " cd ${KERNEL_DIR}"
+ elog " make modules modules_install"
+ elog "This should allow the x11-drm modules to load and function normally."
fi
}
diff --git a/x11-base/x11-drm/x11-drm-20080710.ebuild b/x11-base/x11-drm/x11-drm-20080710.ebuild
index c81950cd9aee..869c7362d50e 100644
--- a/x11-base/x11-drm/x11-drm-20080710.ebuild
+++ b/x11-base/x11-drm/x11-drm-20080710.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20080710.ebuild,v 1.3 2008/09/12 21:30:21 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20080710.ebuild,v 1.4 2008/09/13 01:12:14 battousai Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.7"
@@ -136,10 +136,9 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- CONFIG_CHECK="!DRM ~AGP"
+ CONFIG_CHECK="!DRM AGP"
ERROR_DRM="Please disable DRM in the kernel config. (CONFIG_DRM = n)"
- ERROR_AGP="AGPGART support is not enabled in your kernel config (CONFIG_AGP).
- This will probably be essential for direct rendering."
+ ERROR_AGP="AGPGART support is not enabled in your kernel config (CONFIG_AGP)."
linux-mod_pkg_setup
fi