summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-05-24 19:10:49 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-05-24 19:10:49 +0000
commitb1bad369aa8792388dcb17316bee30ce7898abd6 (patch)
tree9657c61afac847a0defaf78693c435fafd0505e0 /x11-base
parent. (diff)
downloadgentoo-2-b1bad369aa8792388dcb17316bee30ce7898abd6.tar.gz
gentoo-2-b1bad369aa8792388dcb17316bee30ce7898abd6.tar.bz2
gentoo-2-b1bad369aa8792388dcb17316bee30ce7898abd6.zip
(#89852) Ebuild changes for Gentoo/FreeBSD. Set MAKE, use wheel group instead of root, exclude 0700_all_4.2.0-sessreg-highuid.patch on OpenBSD and FreeBSD; the patch allows for high UIDs in a non-portable way. A suitably motivated person could fix it.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-x11/ChangeLog9
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild25
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild25
3 files changed, 38 insertions, 21 deletions
diff --git a/x11-base/xorg-x11/ChangeLog b/x11-base/xorg-x11/ChangeLog
index 587e34b20164..d17994434598 100644
--- a/x11-base/xorg-x11/ChangeLog
+++ b/x11-base/xorg-x11/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-base/xorg-x11
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.394 2005/05/24 07:49:36 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.395 2005/05/24 19:10:49 spyderous Exp $
+
+ 24 May 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ xorg-x11-6.8.2-r2.ebuild, xorg-x11-6.8.99.8.ebuild:
+ (#89852) Ebuild changes for Gentoo/FreeBSD. Set MAKE, use wheel group
+ instead of root, exclude 0700_all_4.2.0-sessreg-highuid.patch on OpenBSD and
+ FreeBSD; the patch allows for high UIDs in a non-portable way. A suitably
+ motivated person could fix it.
24 May 2005; Donnie Berkholz <spyderous@gentoo.org>;
xorg-x11-6.8.2-r2.ebuild:
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild
index 6da20e4b5351..3f5a78095396 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild,v 1.16 2005/05/24 07:49:36 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.2-r2.ebuild,v 1.17 2005/05/24 19:10:49 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -922,6 +922,11 @@ patch_setup() {
else
patch_exclude 5851
fi
+
+ # Glibc-specific patches to exclude for non-glibc systems
+ if use elibc_FreeBSD || use elibc_OpenBSD; then
+ patch_exclude 0700
+ fi
einfo "Done excluding patches."
}
@@ -968,11 +973,11 @@ build() {
FAST=1 ${S}/config/util/makeg.sh World WORLDOPTS="" \
|| die "debug make World failed"
else
- FAST=1 emake World WORLDOPTS="" || die "make World failed"
+ FAST=1 emake World WORLDOPTS="" MAKE="make" || die "make World failed"
fi
if use nls; then
- emake -C ${S}/nls || die "nls build failed"
+ emake -C ${S}/nls MAKE="make" || die "nls build failed"
fi
}
@@ -987,29 +992,29 @@ install_everything() {
# gcc3 related fix. Do this during install, so that our
# whole build will not be compiled without mmx instructions.
if [ "$(gcc-version)" != "2.95" ] && use x86; then
- make install DESTDIR=${D} \
+ make install MAKE="make" DESTDIR=${D} \
|| make CDEBUGFLAGS="${CDEBUGFLAGS} -mno-mmx" \
CXXDEBUGFLAGS="${CXXDEBUGFLAGS} -mno-mmx" \
- install DESTDIR=${D} || die "install failed"
+ install MAKE="make" DESTDIR=${D} || die "install failed"
else
- make install DESTDIR=${D} || die "install failed"
+ make install MAKE="make" DESTDIR=${D} || die "install failed"
fi
if use sdk; then
einfo "Installing X.org X11 SDK..."
- make install.sdk DESTDIR=${D} || die "sdk install failed"
+ make install.sdk MAKE="make" DESTDIR=${D} || die "sdk install failed"
fi
if ! use minimal; then
einfo "Installing man pages..."
- make install.man DESTDIR=${D} || die "man page install failed"
+ make install.man MAKE="make" DESTDIR=${D} || die "man page install failed"
einfo "Compressing man pages..."
prepman /usr
fi
if use nls; then
cd ${S}/nls
- make DESTDIR=${D} install || die "nls install failed"
+ make MAKE="make" DESTDIR=${D} install || die "nls install failed"
fi
dodoc ${S}/RELNOTES
}
@@ -1949,7 +1954,7 @@ setup_tmp_files() {
mkdir -p ${x}
fi
- chown root:root ${x}
+ chown root:wheel ${x}
chmod 1777 ${x}
done
}
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild
index d79df139d26d..f74952ee5435 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild,v 1.2 2005/05/24 07:34:24 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.99.8.ebuild,v 1.3 2005/05/24 19:10:49 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -930,6 +930,11 @@ patch_setup() {
else
patch_exclude 5851
fi
+
+ # Glibc-specific patches to exclude for non-glibc systems
+ if use elibc_FreeBSD || use elibc_OpenBSD; then
+ patch_exclude 0700
+ fi
einfo "Done excluding patches."
}
@@ -976,11 +981,11 @@ build() {
FAST=1 ${S}/config/util/makeg.sh World WORLDOPTS="" \
|| die "debug make World failed"
else
- FAST=1 emake World WORLDOPTS="" || die "make World failed"
+ FAST=1 emake World WORLDOPTS="" MAKE="make" || die "make World failed"
fi
if use nls; then
- emake -C ${S}/nls || die "nls build failed"
+ emake -C ${S}/nls MAKE="make" || die "nls build failed"
fi
}
@@ -995,29 +1000,29 @@ install_everything() {
# gcc3 related fix. Do this during install, so that our
# whole build will not be compiled without mmx instructions.
if [ "$(gcc-version)" != "2.95" ] && use x86; then
- make install DESTDIR=${D} \
+ make install MAKE="make" DESTDIR=${D} \
|| make CDEBUGFLAGS="${CDEBUGFLAGS} -mno-mmx" \
CXXDEBUGFLAGS="${CXXDEBUGFLAGS} -mno-mmx" \
- install DESTDIR=${D} || die "install failed"
+ install MAKE="make" DESTDIR=${D} || die "install failed"
else
- make install DESTDIR=${D} || die "install failed"
+ make install MAKE="make" DESTDIR=${D} || die "install failed"
fi
if use sdk; then
einfo "Installing X.org X11 SDK..."
- make install.sdk DESTDIR=${D} || die "sdk install failed"
+ make install.sdk MAKE="make" DESTDIR=${D} || die "sdk install failed"
fi
if ! use minimal; then
einfo "Installing man pages..."
- make install.man DESTDIR=${D} || die "man page install failed"
+ make install.man MAKE="make" DESTDIR=${D} || die "man page install failed"
einfo "Compressing man pages..."
prepman /usr
fi
if use nls; then
cd ${S}/nls
- make DESTDIR=${D} install || die "nls install failed"
+ make MAKE="make" DESTDIR=${D} install || die "nls install failed"
fi
dodoc ${S}/RELNOTES
}
@@ -1957,7 +1962,7 @@ setup_tmp_files() {
mkdir -p ${x}
fi
- chown root:root ${x}
+ chown root:wheel ${x}
chmod 1777 ${x}
done
}