summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-05 06:31:20 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-05 06:31:20 +0000
commitc5ef8b0bb0f48252590c28c3da54529d95c381f9 (patch)
treea6e0dd803f7c32c04ae25fe62a11fca868c5a0ca /x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild
parentBump for X.Org 7.4. (diff)
downloadgentoo-2-c5ef8b0bb0f48252590c28c3da54529d95c381f9.tar.gz
gentoo-2-c5ef8b0bb0f48252590c28c3da54529d95c381f9.tar.bz2
gentoo-2-c5ef8b0bb0f48252590c28c3da54529d95c381f9.zip
Bump for X.Org 7.4.
(Portage version: 2.1.5.6)
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild
new file mode 100644
index 000000000000..2741f35c9429
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.1.ebuild,v 1.1 2008/07/05 06:31:20 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.4.0.90
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}