summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-09-01 18:01:32 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-09-01 18:01:32 +0000
commit6b027b6daa38a2809f8ab489d352053d6ccd423e (patch)
treeca76d9ad7d959a2d51ddfa6cb7d2755af609fc52 /x11-drivers/xf86-input-wacom
parent[www-apps/rutorrent] Fix bug #378747 and #379249 (diff)
downloadgentoo-2-6b027b6daa38a2809f8ab489d352053d6ccd423e.tar.gz
gentoo-2-6b027b6daa38a2809f8ab489d352053d6ccd423e.tar.bz2
gentoo-2-6b027b6daa38a2809f8ab489d352053d6ccd423e.zip
Version bump, bug #381453.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 0ac724918d25..5cb7224cd37d 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.46 2011/07/29 10:50:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.47 2011/09/01 18:01:32 chithanh Exp $
+
+*xf86-input-wacom-0.11.1 (01 Sep 2011)
+
+ 01 Sep 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-input-wacom-0.11.1.ebuild:
+ Version bump, bug #381453.
29 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
xf86-input-wacom-0.11.0.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.1.ebuild
new file mode 100644
index 000000000000..75b6fa5bd329
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.11.1.ebuild,v 1.1 2011/09/01 18:01:32 chithanh Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND="!x11-drivers/linuxwacom
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${D}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}