summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-11-23 03:59:56 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-11-23 03:59:56 +0000
commit7240b0488711adfadcf83319aecaf96b61f0c2a0 (patch)
tree12ca9189a0bb692d798c9fcaf330490e82d1a499 /x11-drivers/xf86-video-tdfx
parentNew version with symlinks back (diff)
downloadgentoo-2-7240b0488711adfadcf83319aecaf96b61f0c2a0.tar.gz
gentoo-2-7240b0488711adfadcf83319aecaf96b61f0c2a0.tar.bz2
gentoo-2-7240b0488711adfadcf83319aecaf96b61f0c2a0.zip
Version bump. Includes a DRI locking fix for 7.1 servers.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'x11-drivers/xf86-video-tdfx')
-rw-r--r--x11-drivers/xf86-video-tdfx/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.3.06
-rw-r--r--x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.3.0.ebuild30
3 files changed, 43 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-tdfx/ChangeLog b/x11-drivers/xf86-video-tdfx/ChangeLog
index 722ab87cfca0..46800cb778db 100644
--- a/x11-drivers/xf86-video-tdfx/ChangeLog
+++ b/x11-drivers/xf86-video-tdfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-tdfx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/ChangeLog,v 1.28 2006/10/22 18:11:24 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/ChangeLog,v 1.29 2006/11/23 03:59:56 joshuabaergen Exp $
+
+*xf86-video-tdfx-1.3.0 (23 Nov 2006)
+
+ 23 Nov 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86-video-tdfx-1.3.0.ebuild:
+ Version bump. Includes a DRI locking fix for 7.1 servers.
*xf86-video-tdfx-1.2.2 (21 Oct 2006)
diff --git a/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.3.0 b/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.3.0
new file mode 100644
index 000000000000..5b54f10a6ad2
--- /dev/null
+++ b/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.3.0
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 04c49acb5c5dbde14eabd32d06df6e73 xf86-video-tdfx-1.3.0.tar.bz2 261448
+RMD160 31fc8fa884ad669278344164bc7118b1f5edcec8 xf86-video-tdfx-1.3.0.tar.bz2 261448
+SHA256 6b1a00df5c9628817d08f07c6f18f578950744f3eb63b4397be8b0754e728624 xf86-video-tdfx-1.3.0.tar.bz2 261448
diff --git a/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.3.0.ebuild b/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.3.0.ebuild
new file mode 100644
index 000000000000..9016932c90d0
--- /dev/null
+++ b/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.3.0.ebuild,v 1.1 2006/11/23 03:59:56 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="3Dfx video driver"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}