summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-01-01 20:42:54 +0000
committerMatt Turner <mattst88@gentoo.org>2014-01-01 20:42:54 +0000
commit3f6849c3f1e0d4e18dd3c881af8fb27b1bacd1fd (patch)
tree61ab16c7693da06c6037e373a9b98e27132818db /x11-drivers
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-3f6849c3f1e0d4e18dd3c881af8fb27b1bacd1fd.tar.gz
gentoo-2-3f6849c3f1e0d4e18dd3c881af8fb27b1bacd1fd.tar.bz2
gentoo-2-3f6849c3f1e0d4e18dd3c881af8fb27b1bacd1fd.zip
Add check for INPUT_EVDEV, bug 347749.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog7
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild13
2 files changed, 15 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index dce60cf15cc0..e80ffa079a6a 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-drivers/xf86-input-evdev
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.212 2013/10/13 23:22:45 chithanh Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.213 2014/01/01 20:42:54 mattst88 Exp $
+
+ 01 Jan 2014; Matt Turner <mattst88@gentoo.org> xf86-input-evdev-2.8.2.ebuild:
+ Add check for INPUT_EVDEV, bug 347749.
*xf86-input-evdev-2.8.2 (13 Oct 2013)
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild
index d2c3ccab7776..f9b4ee7e5174 100644
--- a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild,v 1.1 2013/10/13 23:22:45 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.8.2.ebuild,v 1.2 2014/01/01 20:42:54 mattst88 Exp $
EAPI=5
-inherit xorg-2
+inherit linux-info xorg-2
DESCRIPTION="Generic Linux input driver"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
@@ -14,3 +14,10 @@ RDEPEND=">=x11-base/xorg-server-1.12[udev]
DEPEND="${RDEPEND}
>=x11-proto/inputproto-2.1.99.3
>=sys-kernel/linux-headers-2.6"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="INPUT_EVDEV"
+ fi
+ check_extra_config
+}