summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2012-02-26 12:48:16 +0000
committerMagnus Granberg <zorry@gentoo.org>2012-02-26 12:48:16 +0000
commit4251edf6293b916e1a6cebdac554447f5cd4a15b (patch)
treee52238b355b165d3a4af28b20951290f50e75563 /x11-drivers
parentRespect CFLAGS and CC variables. (diff)
downloadgentoo-2-4251edf6293b916e1a6cebdac554447f5cd4a15b.tar.gz
gentoo-2-4251edf6293b916e1a6cebdac554447f5cd4a15b.tar.bz2
gentoo-2-4251edf6293b916e1a6cebdac554447f5cd4a15b.zip
Fix bug #394575 on hardened, link with lazy
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-virtualbox/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-link-lazy.patch16
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild9
3 files changed, 29 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-virtualbox/ChangeLog b/x11-drivers/xf86-video-virtualbox/ChangeLog
index 6a3112617faf..46e95b3ad9b6 100644
--- a/x11-drivers/xf86-video-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-video-virtualbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-virtualbox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.82 2012/02/21 17:10:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.83 2012/02/26 12:48:15 zorry Exp $
+
+ 26 Feb 2012; Magnus Granberg <zorry@gentoo.org>
+ +files/xf86-video-virtualbox-link-lazy.patch,
+ xf86-video-virtualbox-4.1.8.ebuild:
+ Fix bug #394575 for hardened thanks Faustus for the fix
21 Feb 2012; Agostino Sarubbo <ago@gentoo.org>
xf86-video-virtualbox-4.1.8.ebuild:
diff --git a/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-link-lazy.patch b/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-link-lazy.patch
new file mode 100644
index 000000000000..081d4eb36224
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-link-lazy.patch
@@ -0,0 +1,16 @@
+2012-02-26 Magnus Granberg <zorry@gentoo.org>
+
+ #394757
+ * Config.kmk TEMPLATE_VBOXGUESTR3EXE_LDFLAGS.linux add -Wl,-z,lazy
+
+--- Config.kmk 2011-12-19 13:58:30.000000000 +0100
++++ Config.kmk 2012-02-26 12:40:07.497810044 +0100
+@@ -4429,7 +4429,7 @@ else # the gcc guys
+ TEMPLATE_VBOXGUESTR3EXE_TOOL := $(subst GXX,GCC,$(TEMPLATE_VBOXR3EXE_TOOL))
+ TEMPLATE_VBOXGUESTR3EXE_CXXFLAGS = $(TEMPLATE_VBOXR3EXE_CXXFLAGS) -fno-exceptions
+ TEMPLATE_VBOXGUESTR3EXE_LDFLAGS = $(filter-out '$(VBOX_GCC_RPATH_OPT)%,$(TEMPLATE_VBOXR3EXE_LDFLAGS))
+- TEMPLATE_VBOXGUESTR3EXE_LDFLAGS.linux = $(filter-out $(VBOX_GCC_ORIGIN_OPT),$(TEMPLATE_VBOXR3EXE_LDFLAGS.linux))
++ TEMPLATE_VBOXGUESTR3EXE_LDFLAGS.linux = $(filter-out $(VBOX_GCC_ORIGIN_OPT),$(TEMPLATE_VBOXR3EXE_LDFLAGS.linux)) -Wl,-z,lazy
+ endif
+ TEMPLATE_VBOXGUESTR3EXE_INST = $(INST_ADDITIONS)
+ TEMPLATE_VBOXGUESTR3EXE_DEFS := $(filter-out $(ARCH_BITS_DEFS), $(TEMPLATE_VBOXR3EXE_DEFS)) IN_GUEST IN_GUEST_R3 IN_RT_R3 $(VBOX_GC_ARCH_BITS_DEFS)
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild
index 8e4c8e30946b..379b6e50614a 100644
--- a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild,v 1.3 2012/02/21 17:10:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.1.8.ebuild,v 1.4 2012/02/26 12:48:15 zorry Exp $
EAPI=2
-inherit eutils linux-mod multilib python versionator
+inherit eutils linux-mod multilib python versionator toolchain-funcs
MY_P=VirtualBox-${PV}
DESCRIPTION="VirtualBox video driver"
@@ -80,6 +80,11 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-3.2.8-mesa-check.patch" \
"${FILESDIR}/${PN}-4-makeself-check.patch" \
"${FILESDIR}/${PN}-4-mkisofs-check.patch"
+
+ # Patch to link with lazy on hardened #394757
+ if gcc-specs-now ; then
+ epatch "${FILESDIR}/${PN}-link-lazy.patch"
+ fi
}
src_configure() {