summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-25 22:26:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-25 22:26:23 +0000
commit651d1b4c2ef0c788ccd3c98442ae7ba70fb425f6 (patch)
treea50e72a1f127ace67e3a29abe81d9a0bb0de1687 /x11-drivers
parentrevert that icu subslot thing that was committed behind my back. icu subslot ... (diff)
downloadgentoo-2-651d1b4c2ef0c788ccd3c98442ae7ba70fb425f6.tar.gz
gentoo-2-651d1b4c2ef0c788ccd3c98442ae7ba70fb425f6.tar.bz2
gentoo-2-651d1b4c2ef0c788ccd3c98442ae7ba70fb425f6.zip
Add ucode for recent hardware and new power management code.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/radeon-ucode/ChangeLog8
-rw-r--r--x11-drivers/radeon-ucode/radeon-ucode-20130625.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-drivers/radeon-ucode/ChangeLog b/x11-drivers/radeon-ucode/ChangeLog
index 2d05e064bb0d..ffe69e797bff 100644
--- a/x11-drivers/radeon-ucode/ChangeLog
+++ b/x11-drivers/radeon-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/radeon-ucode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.28 2013/05/14 15:44:31 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.29 2013/06/25 22:26:23 chithanh Exp $
+
+*radeon-ucode-20130625 (25 Jun 2013)
+
+ 25 Jun 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +radeon-ucode-20130625.ebuild:
+ Add ucode for recent hardware and new power management code.
*radeon-ucode-20130513 (14 May 2013)
diff --git a/x11-drivers/radeon-ucode/radeon-ucode-20130625.ebuild b/x11-drivers/radeon-ucode/radeon-ucode-20130625.ebuild
new file mode 100644
index 000000000000..effc68cae90e
--- /dev/null
+++ b/x11-drivers/radeon-ucode/radeon-ucode-20130625.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/radeon-ucode-20130625.ebuild,v 1.1 2013/06/25 22:26:23 chithanh Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /lib/firmware/radeon
+ FILES=( *.bin )
+ doins ${FILES[@]} || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at http://wiki.x.org/wiki/radeonBuildHowTo and"
+ ewarn "http://www.gentoo.org/doc/en/xorg-config.xml"
+ fi
+ fi
+}