summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-09-08 12:25:28 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-09-08 12:25:28 +0000
commit75fbf4bc234bec5dac7d496ca7127db7ac308ef5 (patch)
treefbf121d89a6a9fc4939370612e137dd9d8855bea /x11-drivers
parentStable for amd64, wrt bug #484224 (diff)
downloadgentoo-2-75fbf4bc234bec5dac7d496ca7127db7ac308ef5.tar.gz
gentoo-2-75fbf4bc234bec5dac7d496ca7127db7ac308ef5.tar.bz2
gentoo-2-75fbf4bc234bec5dac7d496ca7127db7ac308ef5.zip
Update for new KAVERI firmware, bug #484056.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/radeon-ucode/ChangeLog8
-rw-r--r--x11-drivers/radeon-ucode/radeon-ucode-20130826.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-drivers/radeon-ucode/ChangeLog b/x11-drivers/radeon-ucode/ChangeLog
index 0dd5a99b14af..f0e5bebd55e4 100644
--- a/x11-drivers/radeon-ucode/ChangeLog
+++ b/x11-drivers/radeon-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/radeon-ucode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.31 2013/06/30 19:58:04 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.32 2013/09/08 12:25:28 chithanh Exp $
+
+*radeon-ucode-20130826 (08 Sep 2013)
+
+ 08 Sep 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +radeon-ucode-20130826.ebuild:
+ Update for new KAVERI firmware, bug #484056.
30 Jun 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
-radeon-ucode-20130204.ebuild, -radeon-ucode-20130402.ebuild,
diff --git a/x11-drivers/radeon-ucode/radeon-ucode-20130826.ebuild b/x11-drivers/radeon-ucode/radeon-ucode-20130826.ebuild
new file mode 100644
index 000000000000..f6c34b2a1313
--- /dev/null
+++ b/x11-drivers/radeon-ucode/radeon-ucode-20130826.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/radeon-ucode-20130826.ebuild,v 1.1 2013/09/08 12:25:28 chithanh Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /lib/firmware/radeon
+ FILES=( *.bin )
+ doins ${FILES[@]} || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at http://wiki.gentoo.org/wiki/Radeon#Firmware"
+ fi
+ fi
+}