summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-12-01 09:40:44 +0000
committerMike Auty <ikelos@gentoo.org>2009-12-01 09:40:44 +0000
commitb5ab72fc52ad136b98232821e9676ae7b0b7cf25 (patch)
tree01d0ef0f307e26d6d12bda255783005498490bb0 /x11-drivers
parentremoved old qt-4.6.0_beta mask (diff)
downloadgentoo-2-b5ab72fc52ad136b98232821e9676ae7b0b7cf25.tar.gz
gentoo-2-b5ab72fc52ad136b98232821e9676ae7b0b7cf25.tar.bz2
gentoo-2-b5ab72fc52ad136b98232821e9676ae7b0b7cf25.zip
Version bump xf86-input-wacom to 0.10.2. This now supports hotplugging and autoconfiguration for serial devices.
(Portage version: 2.2_rc52/cvs/Linux i686)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2.ebuild53
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 8fab1b58d081..e3ec80804317 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.4 2009/11/20 13:03:52 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.5 2009/12/01 09:40:44 ikelos Exp $
+
+*xf86-input-wacom-0.10.2 (01 Dec 2009)
+
+ 01 Dec 2009; Mike Auty <ikelos@gentoo.org>
+ +xf86-input-wacom-0.10.2.ebuild:
+ Version bump xf86-input-wacom to 0.10.2. This now supports hotplugging and
+ autoconfiguration for serial devices.
*xf86-input-wacom-0.10.1 (20 Nov 2009)
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2.ebuild
new file mode 100644
index 000000000000..5295df39a349
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.2.ebuild,v 1.1 2009/12/01 09:40:44 ikelos Exp $
+
+EAPI="2"
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://anongit.freedesktop.org/~whot/xf86-input-wacom"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://people.freedesktop.org/~whot/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal debug"
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ x-modular_src_install
+
+ if use hal; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ newins "${S}"/fdi/wacom.fdi 11-x11-wacom.fdi
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ if ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}