summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-13 23:52:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-13 23:52:07 +0000
commitbe26b2bd59c487be617236d2ef24c15a77d09b15 (patch)
tree6d2ce4af923ecc2a01357c18ceafe5b6d1104327 /x11-drivers
parentInitial import for bug #202989 (diff)
downloadgentoo-2-be26b2bd59c487be617236d2ef24c15a77d09b15.tar.gz
gentoo-2-be26b2bd59c487be617236d2ef24c15a77d09b15.tar.bz2
gentoo-2-be26b2bd59c487be617236d2ef24c15a77d09b15.zip
Bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.1.4.ebuild101
2 files changed, 108 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index af21f5e6dd7c..7d8d27de2d74 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.30 2010/02/13 19:17:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.31 2010/02/13 23:52:07 patrick Exp $
+
+*xf86-input-virtualbox-3.1.4 (13 Feb 2010)
+
+ 13 Feb 2010; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-3.1.4.ebuild:
+ Bump
*xf86-input-virtualbox-3.1.2 (13 Feb 2010)
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.1.4.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.1.4.ebuild
new file mode 100644
index 000000000000..b7a8855c58ab
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.1.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.1.4.ebuild,v 1.1 2010/02/13 23:52:07 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils multilib linux-info
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox input driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+
+RDEPEND="x11-base/xorg-server
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+src_prepare() {
+ if kernel_is -ge 2 6 33 ; then
+ # evil patch for new kernels - header moved
+ grep -lR linux/autoconf.h * | xargs sed -i -e 's:<linux/autoconf.h>:<generated/autoconf.h>:' || die "Failed replacing"
+ fi
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/Additions/x11/vboxmouse ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/input
+
+ # xorg-server-1.6.x
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_16.so vboxmouse_drv.so
+ # xorg-server-1.5.x
+ else
+ newins vboxmouse_drv_15.so vboxmouse_drv.so
+ fi
+
+ # install hal information file about the mouse driver
+ if use hal; then
+ cd "${S}/src/VBox/Additions/linux/installer"
+ insinto /usr/share/hal/fdi/information/20thirdparty
+ doins 90-vboxguest.fdi
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxmouse\""
+ elog ""
+ elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
+ elog ""
+ if has_version ">=x11-base/xorg-server-1.5" ; then
+ elog "Starting with 1.5 version, X.Org Server can do mouse auto-detection"
+ elog "you may install the hal information file about the mouse driver:"
+ elog ""
+ elog "/usr/share/hal/fdi/information/20thirdparty/90-vboxguest.fdi"
+ elog ""
+ elog "dropping it into: /etc/hal/fdi/policy/"
+ elog ""
+ fi
+}