summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
commitbc47766e01dc5f8f9db197c198f9c4a5be5ba070 (patch)
treee22951a3c8bf89bb39abad557cf4574f6e3dcd6d /x11-libs/buffy
parentperl testing on ppc; added positive test results (diff)
downloadgentoo-2-bc47766e01dc5f8f9db197c198f9c4a5be5ba070.tar.gz
gentoo-2-bc47766e01dc5f8f9db197c198f9c4a5be5ba070.tar.bz2
gentoo-2-bc47766e01dc5f8f9db197c198f9c4a5be5ba070.zip
modernised
Diffstat (limited to 'x11-libs/buffy')
-rw-r--r--x11-libs/buffy/buffy-0.2-r1.ebuild31
-rw-r--r--x11-libs/buffy/buffy-0.2.ebuild22
2 files changed, 14 insertions, 39 deletions
diff --git a/x11-libs/buffy/buffy-0.2-r1.ebuild b/x11-libs/buffy/buffy-0.2-r1.ebuild
index a4be3cf9fd25..c631f595b74d 100644
--- a/x11-libs/buffy/buffy-0.2-r1.ebuild
+++ b/x11-libs/buffy/buffy-0.2-r1.ebuild
@@ -1,42 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/buffy/buffy-0.2-r1.ebuild,v 1.5 2002/08/01 11:40:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/buffy/buffy-0.2-r1.ebuild,v 1.6 2002/08/05 10:02:51 seemant Exp $
-S=${WORKDIR}/${P}
+inherit libtool
+S=${WORKDIR}/${P}
DESCRIPTION="GTK+ theme engine"
-
SRC_URI="http://reality.sgi.com/offer/src/buffy/${P}.tar.gz"
-
HOMEPAGE="http://reality.sgi.com/offer/src/buffy/"
-LICENSE="X11"
+
SLOT="0"
+LICENSE="X11"
KEYWORDS="x86"
-DEPEND="virtual/glibc
- =x11-libs/gtk+-1.2*"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- libtoolize --force --copy
-}
+DEPEND="=x11-libs/gtk+-1.2*"
src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- assert
-
+ elibtoolize
+ econf || die
emake || die
}
src_install () {
make DESTDIR=${D} install || die
-
dodoc AUTHORS COPYING INSTALL NEWS README ChangeLog
}
-
-
diff --git a/x11-libs/buffy/buffy-0.2.ebuild b/x11-libs/buffy/buffy-0.2.ebuild
index 8d29d0949f26..cb1bc257acba 100644
--- a/x11-libs/buffy/buffy-0.2.ebuild
+++ b/x11-libs/buffy/buffy-0.2.ebuild
@@ -1,34 +1,24 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/buffy/buffy-0.2.ebuild,v 1.6 2002/07/22 13:57:40 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/buffy/buffy-0.2.ebuild,v 1.7 2002/08/05 10:02:51 seemant Exp $
S=${WORKDIR}/${P}
-
DESCRIPTION="GTK+ theme engine"
-
SRC_URI="http://reality.sgi.com/offer/src/buffy/${P}.tar.gz"
-
HOMEPAGE="http://reality.sgi.com/offer/src/buffy/"
-LICENSE="X11"
+
SLOT="0"
+LICENSE="X11"
KEYWORDS="x86"
-DEPEND="virtual/glibc
- =x11-libs/gtk+-1.2*"
+DEPEND="=x11-libs/gtk+-1.2*"
src_compile() {
- ./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} || die
-
+ econf || die
emake || die
}
src_install () {
- # try make prefix=${D}/usr install
-
+ make DESTDIR=${D} install || die
dodoc AUTHORS COPYING INSTALL NEWS README ChangeLog
- try make DESTDIR=${D} install
}
-