summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-10 19:03:00 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-10 19:03:00 +0000
commit825ba51e41eeb61b673bad3c92e99517bac04913 (patch)
tree16932c69e9104fcd60c80ef39a357dff9e0ab25e /x11-libs/colord-gtk
parentVersion bump; gtk support library was split off into x11-libs/colord-gtk. (diff)
downloadgentoo-2-825ba51e41eeb61b673bad3c92e99517bac04913.tar.gz
gentoo-2-825ba51e41eeb61b673bad3c92e99517bac04913.tar.bz2
gentoo-2-825ba51e41eeb61b673bad3c92e99517bac04913.zip
New ebuild for colord's gtk support library, split off from x11-misc/colord; prevents a circular dependency betweek gtk+[colord] and colord[gtk].
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/colord-gtk')
-rw-r--r--x11-libs/colord-gtk/ChangeLog12
-rw-r--r--x11-libs/colord-gtk/colord-gtk-0.1.22.ebuild56
-rw-r--r--x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch38
-rw-r--r--x11-libs/colord-gtk/metadata.xml10
4 files changed, 116 insertions, 0 deletions
diff --git a/x11-libs/colord-gtk/ChangeLog b/x11-libs/colord-gtk/ChangeLog
new file mode 100644
index 000000000000..ad5594b82eea
--- /dev/null
+++ b/x11-libs/colord-gtk/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-libs/colord-gtk
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/colord-gtk/ChangeLog,v 1.1 2012/08/10 19:03:00 tetromino Exp $
+
+*colord-gtk-0.1.22 (10 Aug 2012)
+
+ 10 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +colord-gtk-0.1.22.ebuild, +files/colord-gtk-0.1.22-automagic-vala.patch,
+ +metadata.xml:
+ New ebuild for colord's gtk support library, split off from x11-misc/colord;
+ prevents a circular dependency betweek gtk+[colord] and colord[gtk].
+
diff --git a/x11-libs/colord-gtk/colord-gtk-0.1.22.ebuild b/x11-libs/colord-gtk/colord-gtk-0.1.22.ebuild
new file mode 100644
index 000000000000..f4ad2470657c
--- /dev/null
+++ b/x11-libs/colord-gtk/colord-gtk-0.1.22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/colord-gtk/colord-gtk-0.1.22.ebuild,v 1.1 2012/08/10 19:03:00 tetromino Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="GTK support library for colord"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND=">=dev-libs/glib-2.28:2
+ >=media-libs/lcms-2.2:2
+ x11-libs/gdk-pixbuf:2[introspection?]
+ x11-libs/gtk+:3[X(+),introspection?]
+ x11-misc/colord[introspection?,vala?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )"
+# ${PN} was part of x11-misc/colord until 0.1.22
+RDEPEND="${COMMON_DEPEND}
+ !<x11-misc/colord-0.1.22"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9
+ )
+ vala? ( dev-lang/vala:0.14[vapigen] )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.1.22-automagic-vala.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ VAPIGEN=$(type -P vapigen-0.14)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch b/x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch
new file mode 100644
index 000000000000..5e7519fc7bba
--- /dev/null
+++ b/x11-libs/colord-gtk/files/colord-gtk-0.1.22-automagic-vala.patch
@@ -0,0 +1,38 @@
+From 09cfb7f14f3766c80137a00586579dd2280ffe65 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Fri, 10 Aug 2012 14:34:03 -0400
+Subject: [PATCH] Make vala bindings non-automagic
+
+---
+ configure.ac | 8 ++++++--
+ 1 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b51b7d2..e174c4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -134,7 +134,9 @@ PKG_CHECK_MODULES(LCMS, lcms2 >= 2.2)
+ dnl ---------------------------------------------------------------------------
+ dnl - Build VALA support
+ dnl ---------------------------------------------------------------------------
+-if test x$found_introspection != xno; then
++AC_ARG_ENABLE(vala, AS_HELP_STRING([--enable-vala],[build vala bindings]),
++ enable_vala=$enableval,enable_vala=no)
++if test x$found_introspection != xno -a x$enable_vala != xno; then
+ AC_PATH_PROG([VAPIGEN], [vapigen], [])
+ if test "x$VAPIGEN" = "x"; then
+ has_vapigen="no"
+@@ -144,7 +146,9 @@ if test x$found_introspection != xno; then
+ fi
+ else
+ has_vapigen="no"
+- AC_MSG_WARN([Not introspection found, will not build Vala binding])
++ if test x$found_introspection = xno; then
++ AC_MSG_WARN([introspection not found, will not build Vala binding])
++ fi
+ fi
+ AM_CONDITIONAL(HAVE_VAPIGEN, [test "x$has_vapigen" = "xyes"])
+
+--
+1.7.8.6
+
diff --git a/x11-libs/colord-gtk/metadata.xml b/x11-libs/colord-gtk/metadata.xml
new file mode 100644
index 000000000000..04ca9f3b1043
--- /dev/null
+++ b/x11-libs/colord-gtk/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ <flag name="vala">Generate bindings for <pkg>dev-lang/vala</pkg></flag>
+</use>
+</pkgmetadata>