summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-20 00:01:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-20 00:01:14 +0000
commit1b0b1dd940881924015275c28479fcfd3221e944 (patch)
tree852ae2f33b28c4ea8a4420e48b99ce7a1b8b1b3a /x11-libs/ecore
parentNew version (diff)
downloadgentoo-2-1b0b1dd940881924015275c28479fcfd3221e944.tar.gz
gentoo-2-1b0b1dd940881924015275c28479fcfd3221e944.tar.bz2
gentoo-2-1b0b1dd940881924015275c28479fcfd3221e944.zip
add support for more USE flags as pointed out by DEac
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'x11-libs/ecore')
-rw-r--r--x11-libs/ecore/ecore-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/x11-libs/ecore/ecore-9999.ebuild b/x11-libs/ecore/ecore-9999.ebuild
index 4c8500d51432..fbce159f9b85 100644
--- a/x11-libs/ecore/ecore-9999.ebuild
+++ b/x11-libs/ecore/ecore-9999.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ecore-9999.ebuild,v 1.8 2005/06/18 01:23:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ecore-9999.ebuild,v 1.9 2005/10/20 00:01:14 vapier Exp $
inherit enlightenment
DESCRIPTION="core event abstraction layer and X abstraction layer (nice convenience library)"
-IUSE="X fbcon opengl ssl curl"
+IUSE="X directfb fbcon opengl ssl curl threads dbus"
DEPEND=">=x11-libs/evas-0.9.9
virtual/x11
ssl? ( dev-libs/openssl )
curl? ( net-misc/curl )
+ dbus? ( sys-apps/dbus )
opengl? ( virtual/opengl )"
src_compile() {
@@ -19,15 +20,21 @@ src_compile() {
$(use_enable X ecore-x)
--enable-ecore-job
$(use_enable fbcon ecore-fb)
+ $(use_enable directfb ecore-dfb)
--enable-ecore-evas
$(use_enable opengl ecore-evas-gl)
+ $(use_enable X evas-xrender)
+ $(use_enable directfb ecore-evas-dfb)
$(use_enable fbcon ecore-evas-fb)
+ --enable-ecore-evas-buffer
--enable-ecore-con
+ $(use_enable ssl openssl)
--enable-ecore-ipc
- --enable-ecore-txt
+ $(use_enable dbus ecore-dbus)
--enable-ecore-config
- $(use_with curl curl-config)
- $(use_enable ssl openssl)
+ --enable-ecore-file
+ $(use_enable curl)
+ $(use_enable threads pthreads)
"
enlightenment_src_compile
}