summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-16 05:03:06 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-16 05:03:06 +0000
commit2cc86075585ccd8fe41727c46021a6b400c74847 (patch)
tree4cc9c691b66a151cfc45651e7053f3d5300c5765 /x11-libs/evas/evas-0.9.9.030.ebuild
parentStable x86; notification daemon depend (diff)
downloadgentoo-2-2cc86075585ccd8fe41727c46021a6b400c74847.tar.gz
gentoo-2-2cc86075585ccd8fe41727c46021a6b400c74847.tar.bz2
gentoo-2-2cc86075585ccd8fe41727c46021a6b400c74847.zip
version bump
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'x11-libs/evas/evas-0.9.9.030.ebuild')
-rw-r--r--x11-libs/evas/evas-0.9.9.030.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/x11-libs/evas/evas-0.9.9.030.ebuild b/x11-libs/evas/evas-0.9.9.030.ebuild
new file mode 100644
index 000000000000..b3c412700017
--- /dev/null
+++ b/x11-libs/evas/evas-0.9.9.030.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-0.9.9.030.ebuild,v 1.1 2006/07/16 05:03:06 vapier Exp $
+
+inherit enlightenment
+
+DESCRIPTION="hardware-accelerated canvas API"
+
+IUSE="X directfb fbcon jpeg mmx opengl png sse cairo"
+
+RDEPEND="X? ( || ( x11-libs/libXrender virtual/x11 ) )
+ >=media-libs/imlib2-1.2.0
+ >=dev-libs/eet-0.9.9
+ >=dev-db/edb-1.0.5
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ cairo? ( >=x11-libs/cairo-0.2.0 )
+ dev-util/pkgconfig"
+# X? ( xcb-util )
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11 ) )"
+
+src_compile() {
+ # other *very* fun options:
+ # --enable-cpu-p2-only enable assumption of pentium2/amd cpu
+ # --enable-cpu-p3-only enable assumption of pentium3 and up cpu
+ # --enable-cpu-mmx enable mmx code
+ # --enable-cpu-sse enable sse code
+ # --enable-scale-sample enable sampling scaler code
+ # --enable-scale-smooth enable sampling scaler code
+ # --enable-scale-trilinear enable tri-linear scaler code
+ export MY_ECONF="
+ $(use_enable cairo cairo-x11)
+ $(use_enable mmx cpu-mmx) \
+ $(use_enable sse cpu-mmx) \
+ $(use_enable sse cpu-sse) \
+ $(use_enable X software-x11) \
+ $(use_enable opengl gl-x11) \
+ $(use_enable directfb) \
+ $(use_enable fbcon fb) \
+ --enable-image-loader-eet \
+ --enable-image-loader-edb \
+ --enable-fmemopen \
+ --enable-cpu-c \
+ --enable-scale-smooth \
+ --enable-scale-sample \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-444 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-16-rgb-rot-270 \
+ --enable-convert-16-rgb-rot-90 \
+ --enable-convert-24-rgb-888 \
+ --enable-convert-24-bgr-888 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ --enable-convert-32-rgb-rot-270 \
+ --enable-convert-32-rgb-rot-90 \
+ $(use_enable png image-loader-png) \
+ $(use_enable jpeg image-loader-jpeg)
+ "
+ enlightenment_src_compile
+}