summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-06-10 14:43:22 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-06-10 14:43:22 +0000
commit930452ea1dc946de55eddadd07f7ebe414f440d6 (patch)
treea4110de70350db4b01e9a3583a03d8336c4535b6 /x11-libs/fox/fox-1.0.40.ebuild
parentevo 1.4 and deps (diff)
downloadgentoo-2-930452ea1dc946de55eddadd07f7ebe414f440d6.tar.gz
gentoo-2-930452ea1dc946de55eddadd07f7ebe414f440d6.tar.bz2
gentoo-2-930452ea1dc946de55eddadd07f7ebe414f440d6.zip
Version bump. Fixes bug #21618
Diffstat (limited to 'x11-libs/fox/fox-1.0.40.ebuild')
-rw-r--r--x11-libs/fox/fox-1.0.40.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/fox/fox-1.0.40.ebuild b/x11-libs/fox/fox-1.0.40.ebuild
new file mode 100644
index 000000000000..7d89109d146f
--- /dev/null
+++ b/x11-libs/fox/fox-1.0.40.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.40.ebuild,v 1.1 2003/06/10 14:43:22 rphillips Exp $
+
+IUSE="cups opengl"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily a nd effectively"
+
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+
+HOMEPAGE="http://www.fox-toolkit.org"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc "
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ use cups && myconf="$myconf --enable-cups" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}