summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2013-11-24 20:51:45 +0000
committerMagnus Granberg <zorry@gentoo.org>2013-11-24 20:51:45 +0000
commitad8d893a48201781f6d85175af2714bb87f4346a (patch)
tree5263fdb2f9024dca5eec9e65a4d895914fb29344 /x11-libs/glamor
parentVersion bump, remover older (diff)
downloadgentoo-2-ad8d893a48201781f6d85175af2714bb87f4346a.tar.gz
gentoo-2-ad8d893a48201781f6d85175af2714bb87f4346a.tar.bz2
gentoo-2-ad8d893a48201781f6d85175af2714bb87f4346a.zip
Fix bug 488906 fail load grafic with hardened compiler
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FD79807F)
Diffstat (limited to 'x11-libs/glamor')
-rw-r--r--x11-libs/glamor/ChangeLog5
-rw-r--r--x11-libs/glamor/glamor-0.5.1.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/x11-libs/glamor/ChangeLog b/x11-libs/glamor/ChangeLog
index f6996c09363c..656e4ec1987f 100644
--- a/x11-libs/glamor/ChangeLog
+++ b/x11-libs/glamor/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/glamor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.23 2013/10/08 05:07:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.24 2013/11/24 20:51:45 zorry Exp $
+
+ 24 Nov 2013; Magnus Granberg <zorry@gentoo.org> glamor-0.5.1.ebuild:
+ Fix bug 488906 fail to load driver with hardened compiler
08 Oct 2013; Agostino Sarubbo <ago@gentoo.org> glamor-0.5.1.ebuild:
Stable for x86, wrt bug #475480
diff --git a/x11-libs/glamor/glamor-0.5.1.ebuild b/x11-libs/glamor/glamor-0.5.1.ebuild
index 63d8d7948feb..eec04bcb794e 100644
--- a/x11-libs/glamor/glamor-0.5.1.ebuild
+++ b/x11-libs/glamor/glamor-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.1.ebuild,v 1.8 2013/10/08 05:07:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.1.ebuild,v 1.9 2013/11/24 20:51:45 zorry Exp $
EAPI=5
@@ -10,7 +10,7 @@ XORG_MODULE=driver/
XORG_MODULE_REBUILD=yes
S=${WORKDIR}/${PN}-egl-${PV}
-inherit xorg-2
+inherit xorg-2 toolchain-funcs
DESCRIPTION="OpenGL based 2D rendering acceleration library"
SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
@@ -36,4 +36,8 @@ src_configure() {
src_prepare() {
sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
xorg-2_src_prepare
+ # fail to load grafic driver with hardened compiler #488906
+ if gcc-specs-now ; then
+ append-ldflags -Wl,-z,lazy
+ fi
}