summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-11-20 19:59:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-11-20 19:59:12 +0000
commit42a48e6d0f4be75fb44265533256cacecf7acdd1 (patch)
tree3b49490a0600a40917c68d06731763ddd3c41fc6 /x11-libs/goocanvas
parentDrop old json-glib mask. (diff)
downloadgentoo-2-42a48e6d0f4be75fb44265533256cacecf7acdd1.tar.gz
gentoo-2-42a48e6d0f4be75fb44265533256cacecf7acdd1.tar.bz2
gentoo-2-42a48e6d0f4be75fb44265533256cacecf7acdd1.zip
Version bump. Add introspection support.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/ChangeLog8
-rw-r--r--x11-libs/goocanvas/goocanvas-2.0.1.ebuild82
-rw-r--r--x11-libs/goocanvas/metadata.xml4
3 files changed, 93 insertions, 1 deletions
diff --git a/x11-libs/goocanvas/ChangeLog b/x11-libs/goocanvas/ChangeLog
index bfbf61dd3ad8..de178fd81bbc 100644
--- a/x11-libs/goocanvas/ChangeLog
+++ b/x11-libs/goocanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/goocanvas
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.24 2011/09/28 13:13:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.25 2011/11/20 19:59:12 eva Exp $
+
+*goocanvas-2.0.1 (20 Nov 2011)
+
+ 20 Nov 2011; Gilles Dartiguelongue <eva@gentoo.org> +goocanvas-2.0.1.ebuild,
+ metadata.xml:
+ Version bump. Add introspection support.
28 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> goocanvas-1.0.0.ebuild:
Remove useless libtool archive (libgoocanvas.la) which is causing other pkgs
diff --git a/x11-libs/goocanvas/goocanvas-2.0.1.ebuild b/x11-libs/goocanvas/goocanvas-2.0.1.ebuild
new file mode 100644
index 000000000000..d74bb17faa55
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-2.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-2.0.1.ebuild,v 1.1 2011/11/20 19:59:12 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
+
+inherit gnome2 python
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="http://live.gnome.org/GooCanvas"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples +introspection python"
+
+# python only enables python specific binding override
+RDEPEND=">=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ python? ( >=dev-python/pygobject-2.28 )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-rebuilds
+ --disable-static
+ $(use_enable introspection)
+ $(use_enable python)"
+
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed failed"
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS = python/d" -i bindings/Makefile.am bindings/Makefile.in
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ gnome2_src_prepare
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use python; then
+ python_copy_sources bindings/python
+ python_execute_function -s -d --source-dir bindings/python
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ python_execute_function -s -d --source-dir bindings/python
+ python_clean_installation_image
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}
diff --git a/x11-libs/goocanvas/metadata.xml b/x11-libs/goocanvas/metadata.xml
index dd73b66ea569..4c478e2494cd 100644
--- a/x11-libs/goocanvas/metadata.xml
+++ b/x11-libs/goocanvas/metadata.xml
@@ -4,4 +4,8 @@
<maintainer>
<email>eva@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
+ </use>
</pkgmetadata>