summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-27 16:52:18 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-27 16:52:18 +0000
commit554c4a42d7801592c7955a87f8ee3e076f064dc6 (patch)
treeb85c4a5ca078e89554651b3af9bce0dd24e8c503 /x11-libs/gtk+
parentAdd ~alpha wrt #183038 (diff)
downloadgentoo-2-554c4a42d7801592c7955a87f8ee3e076f064dc6.tar.gz
gentoo-2-554c4a42d7801592c7955a87f8ee3e076f064dc6.tar.bz2
gentoo-2-554c4a42d7801592c7955a87f8ee3e076f064dc6.zip
Fixup autotool handling #168198.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/files/gtk+-1.2.10-automake.patch126
-rw-r--r--x11-libs/gtk+/files/gtk+-1.2.10-cleanup.patch13
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r12.ebuild6
4 files changed, 149 insertions, 3 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index d87eca5dc374..e4728dff2720 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.318 2007/06/14 02:42:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.319 2007/06/27 16:52:18 vapier Exp $
+
+ 27 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/gtk+-1.2.10-automake.patch, +files/gtk+-1.2.10-cleanup.patch,
+ gtk+-1.2.10-r12.ebuild:
+ Fixup autotool handling #168198.
*gtk+-2.10.13 (14 Jun 2007)
diff --git a/x11-libs/gtk+/files/gtk+-1.2.10-automake.patch b/x11-libs/gtk+/files/gtk+-1.2.10-automake.patch
new file mode 100644
index 000000000000..e7b4474618bd
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-1.2.10-automake.patch
@@ -0,0 +1,126 @@
+--- docs/Makefile.am
++++ docs/Makefile.am
+@@ -166,7 +166,7 @@
+ echo $$p; \
+ done
+
+-EXTRA_DIST += \
++EXTRA_DIST = \
+ Changes-1.2.txt \
+ debugging.txt \
+ developers.txt \
+--- gdk/Makefile.am
++++ gdk/Makefile.am
+@@ -30,7 +30,7 @@
+ # setup source file variables
+ #
+ # GDK header files for public installation (non-generated)
+-gdk_public_h_sources = @STRIP_BEGIN@ \
++gdk_public_h_sources = \
+ gdk.h \
+ gdkcursors.h \
+ gdkrgb.h \
+@@ -38,9 +38,8 @@
+ gdkkeysyms.h \
+ gdkprivate.h \
+ gdktypes.h \
+- gdkx.h \
+-@STRIP_END@
+-gdk_c_sources = @STRIP_BEGIN@ \
++ gdkx.h
++gdk_c_sources = \
+ gdk.c \
+ gdkcc.c \
+ gdkcolor.c \
+@@ -71,8 +70,7 @@
+ MwmUtil.h \
+ gxid_lib.h \
+ gxid_proto.h \
+- gxid_lib.c \
+-@STRIP_END@
++ gxid_lib.c
+
+ #
+ # setup GDK sources and their dependancies
+@@ -79,10 +79,6 @@
+ #
+ libgdkinclude_HEADERS = $(gdk_public_h_sources)
+ libgdk_la_SOURCES = $(gdk_c_sources)
+-MAINTAINERCLEANFILES +=
+-EXTRA_HEADERS +=
+-EXTRA_DIST +=
+-EXTRA_DIST +=
+
+ #
+ # rules to generate built sources
+--- gtk/Makefile.am
++++ gtk/Makefile.am
+@@ -41,7 +41,7 @@
+ # setup source file variables
+ #
+ # GTK+ header files for public installation (non-generated)
+-gtk_public_h_sources = @STRIP_BEGIN@ \
++gtk_public_h_sources = \
+ gtk.h \
+ gtkaccelgroup.h \
+ gtkaccellabel.h \
+@@ -150,13 +150,12 @@
+ gtkvscrollbar.h \
+ gtkvseparator.h \
+ gtkwidget.h \
+- gtkwindow.h \
+-@STRIP_END@
++ gtkwindow.h
+ # GTK+ header files that don't get installed
+ gtk_private_h_sources = @STRIP_BEGIN@ \
+ @STRIP_END@
+ # GTK+ C sources to build the library from
+-gtk_c_sources = @STRIP_BEGIN@ \
++gtk_c_sources = \
+ gtkaccelgroup.c \
+ gtkaccellabel.c \
+ gtkadjustment.c \
+@@ -264,8 +263,7 @@
+ gtkwidget.c \
+ gtkwindow.c \
+ fnmatch.c \
+- fnmatch.h \
+-@STRIP_END@
++ fnmatch.h
+ # we use our own built_sources variable rules to avoid automake's
+ # BUILT_SOURCES oddities
+ # we generate frequently rebuild files piggyback on a stamp file, so sources
+@@ -284,10 +282,9 @@
+ gtk.defs \
+ @STRIP_END@
+ # built sources that get installed with the header files
+-gtk_built_public_sources = @STRIP_BEGIN@ \
++gtk_built_public_sources = \
+ gtkmarshal.h \
+- gtktypebuiltins.h \
+-@STRIP_END@
++ gtktypebuiltins.h
+ # non-header sources (headers should be specified in the above variables)
+ # that don't serve as direct make target sources, i.e. they don't have
+ # their own .lo rules and don't get publically installed
+@@ -313,9 +313,8 @@
+ #
+ libgtkinclude_HEADERS = $(gtk_public_h_sources) $(gtk_built_public_sources) gtkfeatures.h
+ libgtk_la_SOURCES = $(gtk_c_sources)
+-MAINTAINERCLEANFILES += $(gtk_built_public_sources) $(gtk_built_sources)
+-EXTRA_HEADERS +=
+-EXTRA_DIST += $(gtk_private_h_sources)
++MAINTAINERCLEANFILES = $(gtk_built_public_sources) $(gtk_built_sources)
++EXTRA_DIST = $(gtk_private_h_sources)
+ EXTRA_DIST += $(gtk_built_sources) $(gtk_built_public_sources) $(gtk_extra_sources)
+
+ #
+@@ -323,7 +322,7 @@
+ #
+ # setup autogeneration dependancies
+ gen_sources = xgen-gdef xgen-gtbh xgen-gtbvc xgen-gtbic xgen-gtbec xgen-gmh xgen-gmc
+-CLEANFILES += $(gen_sources)
++CLEANFILES = $(gen_sources)
+ COPYING: $(gtk_built_public_sources) $(gtk_built_sources)
+ $(OBJECTS): COPYING # this is our oldest-source-stamp
+ # initial creation of the real stamp-* files
diff --git a/x11-libs/gtk+/files/gtk+-1.2.10-cleanup.patch b/x11-libs/gtk+/files/gtk+-1.2.10-cleanup.patch
new file mode 100644
index 000000000000..7846c17aad0c
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-1.2.10-cleanup.patch
@@ -0,0 +1,13 @@
+pull in string prototypes
+
+--- gdk/gdkinputcommon.h
++++ gdk/gdkinputcommon.h
+@@ -24,6 +24,8 @@
+ * GTK+ at ftp://ftp.gtk.org/pub/gtk/.
+ */
+
++#include <string.h>
++
+ #if defined(XINPUT_GXI) || defined(XINPUT_XFREE)
+
+ /* Forward declarations */
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r12.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r12.ebuild
index 2c605f255c6c..44a5c280b278 100644
--- a/x11-libs/gtk+/gtk+-1.2.10-r12.ebuild
+++ b/x11-libs/gtk+/gtk+-1.2.10-r12.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r12.ebuild,v 1.12 2007/01/06 05:09:58 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r12.ebuild,v 1.13 2007/06/27 16:52:18 vapier Exp $
GNOME_TARBALL_SUFFIX="gz"
-WANT_AUTOMAKE=1.4
inherit gnome.org eutils toolchain-funcs autotools
DESCRIPTION="The GIMP Toolkit"
@@ -36,9 +35,12 @@ src_unpack() {
unpack ${P}.tar.gz
cd "${S}"
epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${P}-automake.patch
+ epatch "${FILESDIR}"/${P}-cleanup.patch
epatch "${DISTDIR}"/gtk+-1.2.10-r8-gentoo.diff.bz2
epatch "${FILESDIR}"/${PN}-1.2-locale_fix.patch
epatch "${FILESDIR}"/${P}-as-needed.patch
+ sed -i '/libtool.m4/,/AM_PROG_NM/d' acinclude.m4 #168198
eautoreconf
}