summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-02 00:26:32 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-09-02 00:26:32 +0000
commit8301fae2d4ccbd75daf98f1ad23fe04bc89183da (patch)
tree7fac04454e051247bdb2c7a05ef2be6d8cc3c190 /x11-libs/gtk+
parentupdate maintainers entry (diff)
downloadgentoo-2-8301fae2d4ccbd75daf98f1ad23fe04bc89183da.tar.gz
gentoo-2-8301fae2d4ccbd75daf98f1ad23fe04bc89183da.tar.bz2
gentoo-2-8301fae2d4ccbd75daf98f1ad23fe04bc89183da.zip
fix build on Darwin 10.6 (bug #519058)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog6
-rw-r--r--x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch39
-rw-r--r--x11-libs/gtk+/gtk+-3.12.2.ebuild7
3 files changed, 49 insertions, 3 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 2c5e6c81b960..6dece4570a07 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.732 2014/08/25 11:03:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.733 2014/09/02 00:26:32 ottxor Exp $
+
+ 02 Sep 2014; Christoph Junghans <ottxor@gentoo.org>
+ +files/gtk+-3.12.2-darwin10.6.patch, gtk+-3.12.2.ebuild:
+ fix build on Darwin 10.6 (bug #519058)
25 Aug 2014; Agostino Sarubbo <ago@gentoo.org> gtk+-2.24.24.ebuild,
gtk+-3.12.2.ebuild:
diff --git a/x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch b/x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch
new file mode 100644
index 000000000000..3955677f4c35
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.12.2-darwin10.6.patch
@@ -0,0 +1,39 @@
+Fix for Mac Os 10.7
+
+src_compile:
+gtkapplication-quartz-menu.c:265: error: incompatible type for argument 1 of 'roundf'
+make[4]: *** [libgtk_3_la-gtkapplication-quartz-menu.lo] Error 1
+
+More info:
+https://trac.macports.org/ticket/43283
+https://bugzilla.gnome.org/show_bug.cgi?id=727366
+https://bugs.gentoo.org/show_bug.cgi?id=519058
+
+--- gtk/gtkapplication-quartz-menu.c.orig 2014-05-08 01:40:39.000000000 +0200
++++ gtk/gtkapplication-quartz-menu.c 2014-05-15 11:16:09.000000000 +0200
+@@ -30,6 +30,16 @@
+
+ #import <Cocoa/Cocoa.h>
+
++#if !defined(MAC_OS_X_VERSION_10_7) || \
++MAC_OS_X_VERSION_MAX_ALLOWED < MAC_OS_X_VERSION_10_7
++
++@interface NSScreen (LionAPI)
++- (CGFloat)backingScaleFactor;
++- (NSRect)convertRectToBacking:(NSRect)aRect;
++@end
++
++#endif // 10.7
++
+ #define ICON_SIZE 16
+
+ #define BLACK "#000000"
+@@ -262,7 +272,7 @@
+ }
+
+ theme = gtk_icon_theme_get_default ();
+- scale = roundf ([[NSScreen mainScreen] backingScaleFactor]);
++ scale = [[NSScreen mainScreen] respondsToSelector:@selector(backingScaleFactor)] ? roundf ([[NSScreen mainScreen] backingScaleFactor]) : 1.;
+ info = gtk_icon_theme_lookup_by_gicon_for_scale (theme, icon, ICON_SIZE, scale, GTK_ICON_LOOKUP_USE_BUILTIN);
+
+ if (info != NULL)
diff --git a/x11-libs/gtk+/gtk+-3.12.2.ebuild b/x11-libs/gtk+/gtk+-3.12.2.ebuild
index 11d5d06e00f3..e1185f0283ae 100644
--- a/x11-libs/gtk+/gtk+-3.12.2.ebuild
+++ b/x11-libs/gtk+/gtk+-3.12.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.12.2.ebuild,v 1.8 2014/08/25 11:03:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.12.2.ebuild,v 1.9 2014/09/02 00:26:32 ottxor Exp $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit flag-o-matic gnome2 multilib virtualx
+inherit eutils flag-o-matic gnome2 multilib virtualx
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="http://www.gtk.org/"
@@ -108,6 +108,9 @@ src_prepare() {
replace-flags -O3 -O2
strip-flags
+ # Build fix on Darwin 10.6; bug #519058
+ epatch "${FILESDIR}/${P}-darwin10.6.patch"
+
if ! use test ; then
# don't waste time building tests
strip_builddir SRC_SUBDIRS testsuite Makefile.am