summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-02 09:19:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-02 09:19:41 +0000
commitbebc5a9c301a376a0efa897748595dce99b50274 (patch)
tree89428b5ade13395aeafe47bc237298f217c1516e /x11-libs/gtkglarea
parentVersion bump dev-haskell/happy to 1.18.4 (diff)
downloadgentoo-2-bebc5a9c301a376a0efa897748595dce99b50274.tar.gz
gentoo-2-bebc5a9c301a376a0efa897748595dce99b50274.tar.bz2
gentoo-2-bebc5a9c301a376a0efa897748595dce99b50274.zip
Version bump. Code cleanup and build fixes. New examples.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkglarea')
-rw-r--r--x11-libs/gtkglarea/ChangeLog10
-rw-r--r--x11-libs/gtkglarea/gtkglarea-2.0.1.ebuild43
2 files changed, 51 insertions, 2 deletions
diff --git a/x11-libs/gtkglarea/ChangeLog b/x11-libs/gtkglarea/ChangeLog
index 4739f9bc1079..73da6d664bcb 100644
--- a/x11-libs/gtkglarea/ChangeLog
+++ b/x11-libs/gtkglarea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtkglarea
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglarea/ChangeLog,v 1.35 2008/08/25 22:11:09 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglarea/ChangeLog,v 1.36 2009/08/02 09:19:41 eva Exp $
+
+*gtkglarea-2.0.1 (02 Aug 2009)
+
+ 02 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkglarea-2.0.1.ebuild:
+ Version bump. Code cleanup and build fixes. New examples.
25 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
gtkglarea-1.2.3-r1.ebuild, gtkglarea-1.99.0.ebuild:
diff --git a/x11-libs/gtkglarea/gtkglarea-2.0.1.ebuild b/x11-libs/gtkglarea/gtkglarea-2.0.1.ebuild
new file mode 100644
index 000000000000..f6e73b73ff3c
--- /dev/null
+++ b/x11-libs/gtkglarea/gtkglarea-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglarea/gtkglarea-2.0.1.ebuild,v 1.1 2009/08/02 09:19:41 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GL extensions for gtk+"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=x11-libs/gtk+-2.0.3
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README* docs/*.txt"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-static"
+}
+
+src_prepare() {
+ # Do not build examples
+ sed "s:\(SUBDIRS.*\)examples:\1:" -i Makefile.am Makefile.in || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ cd "${S}"/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins *.c *.h *.lwo README || die "doins failed"
+ fi
+}