summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-08-26 21:49:45 +0000
committerSebastian Pipping <sping@gentoo.org>2011-08-26 21:49:45 +0000
commit697c7209108e9eb4f412e5fcde24450bdadd01a9 (patch)
tree95acde21f19240bbc066e71e27bb8188f8d917dd /x11-libs/gtksourceview
parentRevision bump to fix python3 traceback in equery meta. (diff)
downloadgentoo-2-697c7209108e9eb4f412e5fcde24450bdadd01a9.tar.gz
gentoo-2-697c7209108e9eb4f412e5fcde24450bdadd01a9.tar.bz2
gentoo-2-697c7209108e9eb4f412e5fcde24450bdadd01a9.zip
x11-libs/gtksourceview: Fix compilation against GTK 3.1.x (bug #380387)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog8
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.0.5-r1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index d71bb2fa6a0b..33f6293d8e2a 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.205 2011/07/24 13:23:46 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.206 2011/08/26 21:49:45 sping Exp $
+
+*gtksourceview-3.0.5-r1 (26 Aug 2011)
+
+ 26 Aug 2011; Sebastian Pipping <sping@gentoo.org>
+ +gtksourceview-3.0.5-r1.ebuild:
+ Fix compilation against GTK 3.1.x (bug #380387, thanks to tetromino!)
*gtksourceview-3.0.5 (24 Jul 2011)
diff --git a/x11-libs/gtksourceview/gtksourceview-3.0.5-r1.ebuild b/x11-libs/gtksourceview/gtksourceview-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..7fa7b7b516ee
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.0.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.0.5-r1.ebuild,v 1.1 2011/08/26 21:49:45 sping Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="doc glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.28:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --disable-maintainer-mode
+ --enable-providers
+ $(use_enable glade glade-catalog)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ sed -i -e 's:--warn-all::' gtksourceview/Makefile.in || die
+
+ # Skip broken test until upstream bug #621383 is solved
+ sed -e "/guess-language/d" \
+ -e "/get-language/d" \
+ -i tests/test-languagemanager.c || die
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}