summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-19 18:03:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-19 18:03:20 +0000
commitb3056903dbe6fdc30bee950b75cf18ca78acdb90 (patch)
tree32e48a78e1e83796ff19b91e73c7f938555b6fa1 /x11-libs/libICE/libICE-1.0.7.ebuild
parentx86 stable per bug 338652 (diff)
downloadgentoo-2-b3056903dbe6fdc30bee950b75cf18ca78acdb90.tar.gz
gentoo-2-b3056903dbe6fdc30bee950b75cf18ca78acdb90.tar.bz2
gentoo-2-b3056903dbe6fdc30bee950b75cf18ca78acdb90.zip
Version bump.
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libICE/libICE-1.0.7.ebuild')
-rw-r--r--x11-libs/libICE/libICE-1.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/libICE/libICE-1.0.7.ebuild b/x11-libs/libICE/libICE-1.0.7.ebuild
new file mode 100644
index 000000000000..3618ac44a1da
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libICE/libICE-1.0.7.ebuild,v 1.1 2010/10/19 18:03:20 scarabeus Exp $
+
+EAPI=3
+inherit xorg-2
+
+DESCRIPTION="X.Org ICE library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc ipv6"
+
+RDEPEND="x11-libs/xtrans
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ doc? ( app-text/xmlto )"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop"
+}