summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2009-02-02 19:44:57 +0000
committerNed Ludd <solar@gentoo.org>2009-02-02 19:44:57 +0000
commitb298a91017bbf905ab46a4fd10299c50dd2aba15 (patch)
tree81aa2ba4259345feb4f1973374f13f0f01a22269 /x11-libs/libXt
parentAdd support for .lz/.xz and unify more places with ${DECOMPRESSOR}. (diff)
downloadgentoo-2-b298a91017bbf905ab46a4fd10299c50dd2aba15.tar.gz
gentoo-2-b298a91017bbf905ab46a4fd10299c50dd2aba15.tar.bz2
gentoo-2-b298a91017bbf905ab46a4fd10299c50dd2aba15.zip
- Make libXt cross-compile aware by allowing host system makestrs to be used as a fallback when cross-compile one fails. thanks dberkholz for the better idea on patching
(Portage version: 2.1.6.4/cvs/ [masked]x86_64)
Diffstat (limited to 'x11-libs/libXt')
-rw-r--r--x11-libs/libXt/ChangeLog9
-rw-r--r--x11-libs/libXt/files/libXt-1.0.5-cross.patch12
-rw-r--r--x11-libs/libXt/libXt-1.0.5.ebuild7
3 files changed, 23 insertions, 5 deletions
diff --git a/x11-libs/libXt/ChangeLog b/x11-libs/libXt/ChangeLog
index 387f78989470..2068ae27ad83 100644
--- a/x11-libs/libXt/ChangeLog
+++ b/x11-libs/libXt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libXt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/ChangeLog,v 1.49 2008/01/31 04:27:47 dberkholz Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/ChangeLog,v 1.50 2009/02/02 19:44:57 solar Exp $
+
+ 02 Feb 2009; <solar@gentoo.org> +files/libXt-1.0.5-cross.patch,
+ libXt-1.0.5.ebuild:
+ - Make libXt cross-compile aware by allowing host system makestrs to be used
+ as a fallback when cross-compile one fails
31 Jan 2008; Donnie Berkholz <dberkholz@gentoo.org>; -libXt-1.0.2.ebuild:
Clean up.
diff --git a/x11-libs/libXt/files/libXt-1.0.5-cross.patch b/x11-libs/libXt/files/libXt-1.0.5-cross.patch
new file mode 100644
index 000000000000..b7b1911dacdf
--- /dev/null
+++ b/x11-libs/libXt/files/libXt-1.0.5-cross.patch
@@ -0,0 +1,12 @@
+--- src/Makefile.am.orig 2009-02-02 18:46:49.000000000 +0000
++++ src/Makefile.am 2009-02-02 18:48:09.000000000 +0000
+@@ -97,7 +97,8 @@
+ $(BUILT_HEADER): $(BUILT_SOURCE)
+
+ $(BUILT_SOURCE):
+- $(top_builddir)/util/makestrs -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
++ @# run the makestrs we just built and fall back to host makestrs for cross-compiles when native one fails
++ $(top_builddir)/util/makestrs -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c || makestrs -i $(top_srcdir) $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
+ mkdir -p $(top_builddir)/src
+ mkdir -p $(top_builddir)/include/X11
+ cp StringDefs.h $(top_builddir)/include/X11
diff --git a/x11-libs/libXt/libXt-1.0.5.ebuild b/x11-libs/libXt/libXt-1.0.5.ebuild
index b4806ee536ca..6168940d59b0 100644
--- a/x11-libs/libXt/libXt-1.0.5.ebuild
+++ b/x11-libs/libXt/libXt-1.0.5.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/libXt-1.0.5.ebuild,v 1.12 2007/08/07 13:15:40 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXt/libXt-1.0.5.ebuild,v 1.13 2009/02/02 19:44:57 solar Exp $
# Must be before x-modular eclass is inherited
-# SNAPSHOT="yes"
+SNAPSHOT="yes"
+PATCHES="${FILESDIR}/libXt-1.0.5-cross.patch"
inherit x-modular flag-o-matic