summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-23 14:40:40 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-23 14:40:40 +0000
commitc6c3cc7e4aae234fe288e53123627a8130f0b6fb (patch)
tree437a8b83470923e976ff41010035e78704300701 /x11-libs/libfm
parentVersion bump. Bug 433477. Thanks to Anthony Ryan (diff)
downloadgentoo-2-c6c3cc7e4aae234fe288e53123627a8130f0b6fb.tar.gz
gentoo-2-c6c3cc7e4aae234fe288e53123627a8130f0b6fb.tar.bz2
gentoo-2-c6c3cc7e4aae234fe288e53123627a8130f0b6fb.zip
Rework broken symlink logic once again
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'x11-libs/libfm')
-rw-r--r--x11-libs/libfm/ChangeLog5
-rw-r--r--x11-libs/libfm/libfm-9999.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index e3b7172c066a..a5d6df26397c 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.83 2012/12/02 15:26:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.84 2012/12/23 14:40:40 hwoarang Exp $
+
+ 23 Dec 2012; Markos Chandras <hwoarang@gentoo.org> libfm-9999.ebuild:
+ Rework broken symlink logic once again
02 Dec 2012; Markos Chandras <hwoarang@gentoo.org> libfm-9999.ebuild:
Move it to EAPI5 in order to use sub-slot deps for lxde-base/menu-cache
diff --git a/x11-libs/libfm/libfm-9999.ebuild b/x11-libs/libfm/libfm-9999.ebuild
index 0a840c4a16d7..2e768eb148b0 100644
--- a/x11-libs/libfm/libfm-9999.ebuild
+++ b/x11-libs/libfm/libfm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-9999.ebuild,v 1.31 2012/12/02 15:26:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-9999.ebuild,v 1.32 2012/12/23 14:40:40 hwoarang Exp $
EAPI=5
@@ -50,6 +50,10 @@ src_prepare() {
sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" "${S}"/configure.ac || die
#Remove -Werror for automake-1.12. Bug #421101
sed -i "s:-Werror::" configure.ac || die
+ # Drop the symlink. We will create it later on. 439580
+ sed -i "/@LN_S@ @PACKAGE@-@FMLIBVER@/d" src/Makefile.am \
+ || die "failed to remove the includedir symlink"
+
eautoreconf
rm -r autom4te.cache || die
use vala && export VALAC="$(type -p valac-$(vala_best_api_version))"
@@ -71,10 +75,9 @@ src_configure() {
src_install() {
default
find "${D}" -name '*.la' -exec rm -f '{}' +
- # Remove symlink #439570
- if [[ -h ${D}/usr/include/${PN} ]]; then
- rm "${D}"/usr/include/${PN}
- fi
+ # 439570
+ [[ -d ${D}/usr/include/${PN} ]] \
+ && rm -r ${D}/usr/include/${PN}
}
pkg_preinst() {