summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-02-01 15:24:22 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-02-01 15:24:22 +0000
commit2d8af36300334528905cf69d83a6af6f523f2bbc (patch)
tree127e5e869359cef93e9730e84064241f27f49633 /x11-libs/libva
parentVersion bump, drop pre-release (diff)
downloadgentoo-2-2d8af36300334528905cf69d83a6af6f523f2bbc.tar.gz
gentoo-2-2d8af36300334528905cf69d83a6af6f523f2bbc.tar.bz2
gentoo-2-2d8af36300334528905cf69d83a6af6f523f2bbc.zip
revbump ebuilds to support multilib-build, changes reviewed by aballier
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'x11-libs/libva')
-rw-r--r--x11-libs/libva/ChangeLog14
-rw-r--r--x11-libs/libva/files/libva-1.2.0-autotools-out-of-source-build.patch11
-rw-r--r--x11-libs/libva/libva-1.1.1-r1.ebuild82
-rw-r--r--x11-libs/libva/libva-1.2.0-r1.ebuild89
-rw-r--r--x11-libs/libva/libva-1.2.1-r1.ebuild83
-rw-r--r--x11-libs/libva/libva-9999.ebuild67
6 files changed, 312 insertions, 34 deletions
diff --git a/x11-libs/libva/ChangeLog b/x11-libs/libva/ChangeLog
index 32673111d8fb..446fedc6460d 100644
--- a/x11-libs/libva/ChangeLog
+++ b/x11-libs/libva/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/libva
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.54 2013/06/29 03:43:38 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.55 2014/02/01 15:24:22 axs Exp $
+
+*libva-1.2.0-r1 (01 Feb 2014)
+*libva-1.2.1-r1 (01 Feb 2014)
+*libva-1.1.1-r1 (01 Feb 2014)
+
+ 01 Feb 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/libva-1.2.0-autotools-out-of-source-build.patch,
+ +libva-1.1.1-r1.ebuild, +libva-1.2.0-r1.ebuild, +libva-1.2.1-r1.ebuild,
+ libva-9999.ebuild:
+ revbump ebuilds to support multilib-build, changes reviewed by aballier
*libva-1.2.1 (29 Jun 2013)
diff --git a/x11-libs/libva/files/libva-1.2.0-autotools-out-of-source-build.patch b/x11-libs/libva/files/libva-1.2.0-autotools-out-of-source-build.patch
new file mode 100644
index 000000000000..6d36154ea027
--- /dev/null
+++ b/x11-libs/libva/files/libva-1.2.0-autotools-out-of-source-build.patch
@@ -0,0 +1,11 @@
+--- a/va/Makefile.am 2013-06-26 21:45:56.000000000 -0400
++++ b/va/Makefile.am 2014-01-29 14:41:48.878917222 -0500
+@@ -59,7 +59,7 @@
+
+ libva_ldflags = \
+ $(LDADD) -no-undefined \
+- -Wl,-version-script,libva.syms \
++ -Wl,-version-script,$(top_srcdir)/va/libva.syms \
+ $(NULL)
+
+ lib_LTLIBRARIES = libva.la
diff --git a/x11-libs/libva/libva-1.1.1-r1.ebuild b/x11-libs/libva/libva-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..d1d095044528
--- /dev/null
+++ b/x11-libs/libva/libva-1.1.1-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.1.1-r1.ebuild,v 1.1 2014/02/01 15:24:22 axs Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm egl opengl vdpau wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
+
+VIDEO_CARDS="dummy nvidia intel fglrx"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4[${MULTILIB_USEDEP}]
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ )
+ egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )
+ opengl? ( virtual/opengl[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ vdpau? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? ( x11-libs/xvba-video[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.0.18[${MULTILIB_USEDEP}] )
+ "
+
+REQUIRED_USE="opengl? ( X )"
+
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libva/libva-1.2.0-r1.ebuild b/x11-libs/libva/libva-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..a5472d4108bb
--- /dev/null
+++ b/x11-libs/libva/libva-1.2.0-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.2.0-r1.ebuild,v 1.1 2014/02/01 15:24:22 axs Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm egl opengl vdpau wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
+
+VIDEO_CARDS="dummy nvidia intel fglrx"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4[${MULTILIB_USEDEP}]
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ )
+ egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )
+ opengl? ( virtual/opengl[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ vdpau? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? ( x11-libs/xvba-video[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.0.18[${MULTILIB_USEDEP}] )
+ "
+
+REQUIRED_USE="opengl? ( X )"
+
+PATCHES=( "${FILESDIR}/${P}-autotools-out-of-source-build.patch" )
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ # collision with media-video/mjpegtools
+ mv "${ED}"/usr/bin/{mpeg2enc,mpeg2enc_libva} || die
+}
diff --git a/x11-libs/libva/libva-1.2.1-r1.ebuild b/x11-libs/libva/libva-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..01e9c931c620
--- /dev/null
+++ b/x11-libs/libva/libva-1.2.1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.2.1-r1.ebuild,v 1.1 2014/02/01 15:24:22 axs Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm egl opengl vdpau wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
+
+VIDEO_CARDS="dummy nvidia intel fglrx"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4[${MULTILIB_USEDEP}]
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ )
+ egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )
+ opengl? ( virtual/opengl )
+ wayland? ( >=dev-libs/wayland-1[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ vdpau? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? ( x11-libs/xvba-video[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.0.18[${MULTILIB_USEDEP}] )
+ "
+
+REQUIRED_USE="opengl? ( X )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2.0-autotools-out-of-source-build.patch" )
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 631f6448dfe7..d2eb2cd9d186 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-9999.ebuild,v 1.18 2013/06/29 03:43:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-9999.ebuild,v 1.19 2014/02/01 15:24:22 axs Exp $
-EAPI=4
+EAPI=5
SCM=""
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
@@ -11,7 +11,8 @@ if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
fi
-inherit autotools ${SCM} multilib
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
DESCRIPTION="Video Acceleration (VA) API for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
@@ -37,44 +38,46 @@ for x in ${VIDEO_CARDS}; do
IUSE+=" video_cards_${x}"
done
-RDEPEND=">=x11-libs/libdrm-2.4
+RDEPEND=">=x11-libs/libdrm-2.4[${MULTILIB_USEDEP}]
X? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXfixes
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
)
- egl? ( media-libs/mesa[egl] )
+ egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )
opengl? ( virtual/opengl )
- wayland? ( >=dev-libs/wayland-1 )"
+ wayland? ( >=dev-libs/wayland-1[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-PDEPEND="video_cards_nvidia? ( x11-libs/libva-vdpau-driver )
- vdpau? ( x11-libs/libva-vdpau-driver )
- video_cards_fglrx? ( x11-libs/xvba-video )
- video_cards_intel? ( >=x11-libs/libva-intel-driver-1.0.18 )
+PDEPEND="video_cards_nvidia? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ vdpau? ( x11-libs/libva-vdpau-driver[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? ( x11-libs/xvba-video[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.0.18[${MULTILIB_USEDEP}] )
"
REQUIRED_USE="opengl? ( X )"
-src_prepare() {
- eautoreconf
-}
+PATCHES=( "${FILESDIR}/${PN}-1.2.0-autotools-out-of-source-build.patch" )
+DOCS=( NEWS )
-src_configure() {
- econf \
- --disable-silent-rules \
- --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers" \
- $(use_enable video_cards_dummy dummy-driver) \
- $(use_enable opengl glx) \
- $(use_enable X x11) \
- $(use_enable wayland) \
- $(use_enable egl) \
- $(use_enable drm)
-}
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc NEWS || die
- find "${D}" -name '*.la' -delete
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
}