summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-20 17:48:10 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-20 17:48:10 +0000
commit67ac7d0eaea7eedef5b671503cfdfed2bbfe518f (patch)
tree75d575e1876b63152c421195dca27d0854447d39 /x11-libs/openmotif
parentalpha/sparc stable wrt #307575 (diff)
downloadgentoo-2-67ac7d0eaea7eedef5b671503cfdfed2bbfe518f.tar.gz
gentoo-2-67ac7d0eaea7eedef5b671503cfdfed2bbfe518f.tar.bz2
gentoo-2-67ac7d0eaea7eedef5b671503cfdfed2bbfe518f.zip
Add patch to fix compilation on Mac OS X using patch grabbed from upstream bugtracker
(Portage version: 2.2.00.15819-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'x11-libs/openmotif')
-rw-r--r--x11-libs/openmotif/ChangeLog7
-rw-r--r--x11-libs/openmotif/files/openmotif-2.3.2-darwin.patch14
-rw-r--r--x11-libs/openmotif/openmotif-2.3.3.ebuild9
3 files changed, 25 insertions, 5 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index e2742339f50a..6438867cb014 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/openmotif
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.230 2010/03/19 00:25:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.231 2010/03/20 17:48:09 grobian Exp $
+
+ 20 Mar 2010; Fabian Groffen <grobian@gentoo.org>
+ +files/openmotif-2.3.2-darwin.patch, openmotif-2.3.3.ebuild:
+ Add patch to fix compilation on Mac OS X using patch grabbed from upstream
+ bugtracker
*openmotif-2.3.3 (18 Mar 2010)
diff --git a/x11-libs/openmotif/files/openmotif-2.3.2-darwin.patch b/x11-libs/openmotif/files/openmotif-2.3.2-darwin.patch
new file mode 100644
index 000000000000..feae00305ad6
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.3.2-darwin.patch
@@ -0,0 +1,14 @@
+http://bugs.motifzone.net/showattachment.cgi?attach_id=259
+http://bugs.motifzone.net/long_list.cgi?buglist=1479
+
+--- openmotif-2.3.2.org/clients/uil/UilDefI.h 2004-11-18 08:54:32.000000000 +0000
++++ openmotif-2.3.2/clients/uil/UilDefI.h 2009-11-08 13:24:29.000000000 +0000
+@@ -283,7 +283,7 @@
+ #include "UilIODef.h"
+ #include "UilDiagDef.h"
+ #include "UilSarDef.h"
+-#if defined(linux)
++#if defined(linux) || defined(__APPLE__)
+ #define YYSTYPE yystype
+ #endif
+ #include "UilLexPars.h"
diff --git a/x11-libs/openmotif/openmotif-2.3.3.ebuild b/x11-libs/openmotif/openmotif-2.3.3.ebuild
index 64916e98827a..24405739c8d6 100644
--- a/x11-libs/openmotif/openmotif-2.3.3.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.3.ebuild,v 1.1 2010/03/19 00:25:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.3.ebuild,v 1.2 2010/03/20 17:48:09 grobian Exp $
-EAPI=3
+EAPI="3"
inherit autotools eutils flag-o-matic multilib
@@ -79,6 +79,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.2-darwin.patch"
epatch "${FILESDIR}/${PN}-2.3.2-sanitise-paths.patch"
epatch "${FILESDIR}/${PN}-2.3.2-libpng14.patch"
[[ ${CHOST} == *-solaris2.11 ]] \
@@ -123,11 +124,11 @@ src_configure() {
}
src_compile() {
- emake -j1 MWMRCDIR=/etc/X11/mwm || die "emake failed"
+ emake -j1 MWMRCDIR="${EPREFIX}"/etc/X11/mwm || die "emake failed"
}
src_install() {
- emake -j1 DESTDIR="${D}" MWMRCDIR=/etc/X11/mwm install \
+ emake -j1 DESTDIR="${D}" MWMRCDIR="${EPREFIX}"/etc/X11/mwm install \
|| die "emake install failed"
# mwm default configs