summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-09-28 14:59:29 +0000
committerMart Raudsepp <leio@gentoo.org>2006-09-28 14:59:29 +0000
commit16230ae07ff40713b044cf27e794416963374433 (patch)
treeb5170de9e1cf6ee991457746a6c4474a89aac6e8 /x11-libs/pango
parentPrevent collision-protect error (portage bug) (diff)
downloadgentoo-2-16230ae07ff40713b044cf27e794416963374433.tar.gz
gentoo-2-16230ae07ff40713b044cf27e794416963374433.tar.bz2
gentoo-2-16230ae07ff40713b044cf27e794416963374433.zip
New pango
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog8
-rw-r--r--x11-libs/pango/files/digest-pango-1.14.43
-rw-r--r--x11-libs/pango/pango-1.14.4.ebuild75
3 files changed, 85 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 8cab809752e7..060212a7a3c4 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.148 2006/09/07 02:52:21 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.149 2006/09/28 14:59:29 leio Exp $
+
+*pango-1.14.4 (28 Sep 2006)
+
+ 28 Sep 2006; Mart Raudsepp <leio@gentoo.org> -pango-1.14.3.ebuild,
+ +pango-1.14.4.ebuild:
+ Updated version for gnome 2.16
*pango-1.14.3 (07 Sep 2006)
diff --git a/x11-libs/pango/files/digest-pango-1.14.4 b/x11-libs/pango/files/digest-pango-1.14.4
new file mode 100644
index 000000000000..b6c47ccaa063
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.14.4
@@ -0,0 +1,3 @@
+MD5 a1549ab27aa4555c55f555870e36d60b pango-1.14.4.tar.bz2 1286770
+RMD160 a7c99a69aec51997bbec8ef989367051bd99e453 pango-1.14.4.tar.bz2 1286770
+SHA256 53e2790fd006763fba9d25773c2f85b25b794a00177f9e5cdf660368d88159fe pango-1.14.4.tar.bz2 1286770
diff --git a/x11-libs/pango/pango-1.14.4.ebuild b/x11-libs/pango/pango-1.14.4.ebuild
new file mode 100644
index 000000000000..6224d964b9b7
--- /dev/null
+++ b/x11-libs/pango/pango-1.14.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.14.4.ebuild,v 1.1 2006/09/28 14:59:29 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="|| (
+ (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ )
+ virtual/x11
+ )
+ >=dev-libs/glib-2.10.0
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.2.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ || ( x11-proto/xproto virtual/x11 )
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Some enhancements from Redhat
+ # These NEED to go upstream.
+ epatch ${FILESDIR}/pango-1.11.3-xfonts.patch
+ epatch ${FILESDIR}/${PN}-1.10.2-slighthint.patch
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system
+ use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Generating modules listing..."
+
+ use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
+
+ PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}