summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-03 22:22:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-03 22:22:26 +0000
commitda63dd23aecf243ca7923dc56ce35c6921ac89fc (patch)
tree484f315e4d008a2988083da0139c4c701cb860e6 /x11-libs/pango
parentVersion bump (fixes bug #301502, thanks to Roger <rogerx@sdf.org> for reporti... (diff)
downloadgentoo-2-da63dd23aecf243ca7923dc56ce35c6921ac89fc.tar.gz
gentoo-2-da63dd23aecf243ca7923dc56ce35c6921ac89fc.tar.bz2
gentoo-2-da63dd23aecf243ca7923dc56ce35c6921ac89fc.zip
Version bump. Bug fixes, introspection updates.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/pango-1.28.3.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index b6b0d5e0f3c4..1c63279b8de5 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.296 2010/10/02 15:30:42 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.297 2010/10/03 22:22:26 eva Exp $
+
+*pango-1.28.3 (03 Oct 2010)
+
+ 03 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> +pango-1.28.3.ebuild:
+ Version bump. Bug fixes, introspection updates.
02 Oct 2010; Tobias Klausmann <klausman@gentoo.org> pango-1.28.1.ebuild:
Stable on alpha, bug #313331
diff --git a/x11-libs/pango/pango-1.28.3.ebuild b/x11-libs/pango/pango-1.28.3.ebuild
new file mode 100644
index 000000000000..dfb1c7aee197
--- /dev/null
+++ b/x11-libs/pango/pango-1.28.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.28.3.ebuild,v 1.1 2010/10/03 22:22:26 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 multilib toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X doc +introspection test"
+
+RDEPEND=">=dev-libs/glib-2.17.3
+ >=media-libs/fontconfig-2.5.0
+ media-libs/freetype:2
+ >=x11-libs/cairo-1.7.6[X?]
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.13
+ doc? (
+ >=dev-util/gtk-doc-1.13
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ test? (
+ >=dev-util/gtk-doc-1.13
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ X? ( x11-proto/xproto )"
+
+DOCS="AUTHORS ChangeLog* NEWS README THANKS"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" = "lib32" ] )
+}
+
+pkg_setup() {
+ tc-export CXX
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_with X x)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.26.0-lib64.patch"
+ fi
+
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}/usr/$(get_libdir)/pango/1.6.0/modules" -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}