summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-24 15:06:13 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-24 15:06:13 +0000
commit3b1cf55ccaf300492961191622cf65b59afcceca (patch)
tree8dd7cad084beca42259ca75d26bcfeae76a77ddc /x11-libs/qt-core
parentMarking dpkg-1.13.25 ppc for bug 203220 (diff)
downloadgentoo-2-3b1cf55ccaf300492961191622cf65b59afcceca.tar.gz
gentoo-2-3b1cf55ccaf300492961191622cf65b59afcceca.tar.bz2
gentoo-2-3b1cf55ccaf300492961191622cf65b59afcceca.zip
If we already have a qconfig.pri on the system, don't overwrite it with a new one
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'x11-libs/qt-core')
-rw-r--r--x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild b/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild
index a297ae71095f..ad156f3240d8 100644
--- a/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild,v 1.6 2007/12/23 20:55:17 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild,v 1.7 2007/12/24 15:06:13 caleb Exp $
EAPI=1
@@ -78,8 +78,12 @@ src_install() {
cat > "${T}/44qt4" << EOF
LDPATH=${libdirs:1}
EOF
-
doenvd "${T}/44qt4"
+
+ # If we already have a qconfig.pri installed on the system, don't overwrite it with a new one.
+ if [ -a ${QTDATADIR}/mkspecs/qconfig.pri ]; then
+ rm "${D}"/${QTDATDIR}/mkspecs/qconfig.pri
+ fi
}
pkg_setup() {