summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-04-14 23:13:48 +0000
committerAlex Alexander <wired@gentoo.org>2011-04-14 23:13:48 +0000
commit5eaa543b592f191e6bfae11231c298cb39b06b7d (patch)
tree0b50c662cd7da595c3b6de9927b8a1501dd082e7 /x11-libs/qt-phonon
parentApply the akonadi-optional patch conditionally (diff)
downloadgentoo-2-5eaa543b592f191e6bfae11231c298cb39b06b7d.tar.gz
gentoo-2-5eaa543b592f191e6bfae11231c298cb39b06b7d.tar.bz2
gentoo-2-5eaa543b592f191e6bfae11231c298cb39b06b7d.zip
added qt3support use flag, fixes bug #346355.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog6
-rw-r--r--x11-libs/qt-phonon/metadata.xml2
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild11
3 files changed, 13 insertions, 6 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index 6495d65c0abc..9950f4b284db 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.90 2011/04/13 21:08:11 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.91 2011/04/14 23:13:48 wired Exp $
+
+ 14 Apr 2011; Alex Alexander <wired@gentoo.org> qt-phonon-4.7.2.ebuild,
+ metadata.xml:
+ added qt3support use flag, fixes bug #346355.
13 Apr 2011; Alex Alexander <wired@gentoo.org> -qt-phonon-4.7.0.ebuild,
-qt-phonon-4.7.1.ebuild:
diff --git a/x11-libs/qt-phonon/metadata.xml b/x11-libs/qt-phonon/metadata.xml
index e34a8eb7ed3e..cd68118d37a5 100644
--- a/x11-libs/qt-phonon/metadata.xml
+++ b/x11-libs/qt-phonon/metadata.xml
@@ -5,5 +5,7 @@
<use>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
+ <flag name='qt3support'>Enable the Qt3Support libraries for Qt4. Note that
+ this does not mean you can compile pure Qt3 programs with Qt4.</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild b/x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild
index e52b722f0903..61e0ef940be0 100644
--- a/x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild
+++ b/x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild,v 1.2 2011/03/26 16:49:00 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.7.2.ebuild,v 1.3 2011/04/14 23:13:48 wired Exp $
EAPI="3"
inherit qt4-build
@@ -8,16 +8,16 @@ inherit qt4-build
DESCRIPTION="The Phonon module for the Qt toolkit"
SLOT="4"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="dbus"
+IUSE="dbus qt3support"
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,glib,qt3support]
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,qt3support=]
!kde-base/phonon-kde
!kde-base/phonon-xine
!media-libs/phonon
!media-sound/phonon
!aqua? ( media-libs/gstreamer
media-plugins/gst-plugins-meta )
- aqua? ( ~x11-libs/qt-opengl-${PV}[aqua] )
+ aqua? ( ~x11-libs/qt-opengl-${PV}[aqua,qt3support=] )
dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )"
RDEPEND="${DEPEND}"
@@ -39,7 +39,8 @@ pkg_setup() {
src_configure() {
myconf="${myconf} -phonon -phonon-backend -no-opengl -no-svg
- $(qt_use dbus qdbus)"
+ $(qt_use dbus qdbus)
+ $(qt_use qt3support)"
qt4-build_src_configure
}