summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:46:45 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:46:45 +0000
commit6a8d46945638857ea48ab47ffc536129b9e24024 (patch)
tree3db2b3f001fdf7a3d2c8790d3719e7aec8364350 /x11-libs/qt-phonon
parentVersion bump to Qt-4.4.0. (diff)
downloadgentoo-2-6a8d46945638857ea48ab47ffc536129b9e24024.tar.gz
gentoo-2-6a8d46945638857ea48ab47ffc536129b9e24024.tar.bz2
gentoo-2-6a8d46945638857ea48ab47ffc536129b9e24024.zip
Version bump to Qt-4.4.0.
(Portage version: 2.1.5)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog7
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.4.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index fcda55e6acda..479c2cc97f94 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.4 2008/04/10 13:41:46 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.5 2008/05/15 12:46:45 ingmar Exp $
+
+*qt-phonon-4.4.0 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +qt-phonon-4.4.0.ebuild:
+ Version bump to Qt-4.4.0.
10 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-qt-phonon-4.4.0_beta1.ebuild, +qt-phonon-4.4.0_rc1.ebuild:
diff --git a/x11-libs/qt-phonon/qt-phonon-4.4.0.ebuild b/x11-libs/qt-phonon/qt-phonon-4.4.0.ebuild
new file mode 100644
index 000000000000..ac5897bbecac
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.4.0.ebuild,v 1.1 2008/05/15 12:46:45 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ dbus? ( =x11-libs/qt-dbus-${PV} )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/phonon
+src/plugins/phonon"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+src/3rdparty/kdelibs/phonon/
+src/3rdparty/kdebase/runtime/phonon/"
+QCONFIG_ADD="phonon"
+QCONFIG_DEFINE="QT_GSTREAMER"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -phonon -no-opengl -no-svg
+ $(qt_use dbus qdbus)"
+
+ qt4-build_src_compile
+}