summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-01-15 14:50:36 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-01-15 14:50:36 +0000
commit80d1ec8d9f4a973af2333885c47c48fccf66f95f (patch)
treee617de6dd0b80bce82509de42414387210bdcc3f /x11-libs/qt-svg
parentPrefix boost detection fix (diff)
downloadgentoo-2-80d1ec8d9f4a973af2333885c47c48fccf66f95f.tar.gz
gentoo-2-80d1ec8d9f4a973af2333885c47c48fccf66f95f.tar.bz2
gentoo-2-80d1ec8d9f4a973af2333885c47c48fccf66f95f.zip
Revision bump, add accessibility USE flag to fix crash caused by splitting qt-svg from qt-gui, bug 301476, thanks to Jaak Ristioja and Davide Pesavento for the patch
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog12
-rw-r--r--x11-libs/qt-svg/qt-svg-4.7.1-r1.ebuild50
2 files changed, 60 insertions, 2 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 676297f89c96..a6e426082661 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-svg
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.81 2010/12/23 07:56:58 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.82 2011/01/15 14:50:36 tampakrap Exp $
+
+*qt-svg-4.7.1-r1 (15 Jan 2011)
+
+ 15 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-svg-4.7.1-r1.ebuild:
+ Revision bump, add accessibility USE flag to fix crash caused by splitting
+ qt-svg from qt-gui, bug 301476, thanks to Jaak Ristioja and Davide Pesavento
+ for the patch
23 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> qt-svg-4.6.3.ebuild:
ppc64 stable wrt #341703
diff --git a/x11-libs/qt-svg/qt-svg-4.7.1-r1.ebuild b/x11-libs/qt-svg/qt-svg-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..0dbf1686dfe4
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.7.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.7.1-r1.ebuild,v 1.1 2011/01/15 14:50:36 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/svg
+ src/plugins/imageformats/svg
+ src/plugins/iconengines/svgiconengine"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtSvg/
+ include/Qt/
+ include/QtGui/
+ include/QtCore/
+ include/QtXml/
+ src/corelib/
+ src/gui/
+ src/plugins/
+ src/xml
+ src/3rdparty"
+
+ QCONFIG_ADD="svg"
+ QCONFIG_DEFINE="QT_SVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -svg
+ $(qt_use iconv)
+ $(qt_use accessibility)
+ -no-xkb -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-fontconfig -no-glib -no-gtkstyle"
+ qt4-build_src_configure
+}