summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-08 09:22:28 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-08 09:22:28 +0000
commit344ceaf01e5d5d1c6ac10523bb168c021b921f0d (patch)
tree5c8b748b1c86e4816f9b3364b08ab0971a1df8e1 /x11-libs/qt-test
parentversion bump, 4.7.4 (diff)
downloadgentoo-2-344ceaf01e5d5d1c6ac10523bb168c021b921f0d.tar.gz
gentoo-2-344ceaf01e5d5d1c6ac10523bb168c021b921f0d.tar.bz2
gentoo-2-344ceaf01e5d5d1c6ac10523bb168c021b921f0d.zip
version bump, 4.7.4
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog7
-rw-r--r--x11-libs/qt-test/qt-test-4.7.4.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 00289c31db3a..2b5836cc55a6 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.90 2011/08/17 16:59:25 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.91 2011/09/08 09:22:28 wired Exp $
+
+*qt-test-4.7.4 (08 Sep 2011)
+
+ 08 Sep 2011; Alex Alexander <wired@gentoo.org> +qt-test-4.7.4.ebuild:
+ version bump, 4.7.4
17 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
qt-test-4.6.3.ebuild:
diff --git a/x11-libs/qt-test/qt-test-4.7.4.ebuild b/x11-libs/qt-test/qt-test-4.7.4.ebuild
new file mode 100644
index 000000000000..5e4ee05c084c
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.7.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.7.4.ebuild,v 1.1 2011/09/08 09:22:28 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/testlib"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtTest/
+ include/QtCore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg"
+ qt4-build_src_configure
+}